Bug 1470375 - Since upgrade from libvirt 3.4 to libvirt 3.5, virt-customize is no longer able to find /
Since upgrade from libvirt 3.4 to libvirt 3.5, virt-customize is no longer ab...
Status: CLOSED DUPLICATE of bug 1470157
Product: Fedora
Classification: Fedora
Component: libguestfs (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-12 16:43 EDT by David Hill
Modified: 2017-07-12 16:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-12 16:51:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Hill 2017-07-12 16:43:39 EDT
Description of problem:
Since upgrade from libvirt 3.4 to libvirt 3.5, virt-customize is no longer able to find /

supermin: picked /sys/block/sdb/dev as root device
supermin: creating /dev/root as block special 8:16
supermin: mounting new root on /root
[    0.946455] EXT4-fs (sdb): mounting ext2 file system using the ext4 subsystem
[    0.952623] EXT4-fs (sdb): mounted filesystem without journal. Opts: 
supermin: deleting initramfs files
supermin: chroot
execl: /init: No such file or directory
supermin: debug: listing directory /
  592 d run              040755 4096 0:0
    2 d ..               040755 4096 0:0
  589 d opt              040755 4096 0:0
   12 - init             100755 6643 0:0
  607 d tmp              041777 4096 0:0
  597 l sbin             120777 8 0:0 -> \xe\x18
  532 d home             040755 4096 0:0
    2 d .                040755 4096 0:0
 7365 d var              040755 4096 0:0
  605 d srv              040755 4096 0:0
   11 d lost+found       040700 16384 0:0
   13 d etc              040755 4096 0:0
  535 l lib64            120777 9 0:0 -> \x18\x12
  587 d media            040755 4096 0:0
  533 l lib              120777 7 0:0 -> \x16\x12
  205 d boot             040555 4096 0:0
  175 d usr              040755 4096 0:0
  206 d dev              040755 4096 0:0
  200 l bin              120777 7 0:0 -> G\b
  588 d mnt              040755 4096 0:0
  606 d sys              040555 4096 0:0
  590 d proc             040555 4096 0:0
  591 d root             040550 4096 0:0

supermin: debug: listing directory /bin
/bin: No such file or directory
supermin: debug: listing directory /lib
/lib: No such file or directory
supermin: debug: listing directory /lib64
/lib64: No such file or directory
[    1.014502] Kernel panic - not syncing: Attempted to kill init! exitcode=0x00000100
[    1.014502] 
[    1.015731] CPU: 0 PID: 1 Comm: init Not tainted 4.13.0-0.rc0.git4.1.fc27.x86_64 #1
[    1.016745] Hardware name: QEMU Standard PC (i440FX + PIIX, 1996), BIOS 1.10.2-1.fc27 04/01/2014
[    1.017915] Call Trace:
[    1.018255]  dump_stack+0x8e/0xd6
[    1.018704]  panic+0xe9/0x23d
[    1.019126]  do_exit+0xcfb/0xd30
[    1.019565]  ? trace_hardirqs_on_caller+0xf4/0x190
[    1.020221]  SyS_exit+0x17/0x20
[    1.020651]  entry_SYSCALL_64_fastpath+0x1f/0xbe
[    1.021293] RIP: 0033:0x400e03
[    1.021707] RSP: 002b:00007ffc289b9758 EFLAGS: 00000246 ORIG_RAX: 000000000000003c
[    1.022710] RAX: ffffffffffffffda RBX: 0000000000404010 RCX: 0000000000400e03
[    1.023664] RDX: 0000000000000001 RSI: 0000000000000000 RDI: 0000000000000001
[    1.024606] RBP: 00007ff226337000 R08: 0000000000403b60 R09: 0000000000000000
[    1.025543] R10: 0000000000400e03 R11: 0000000000000246 R12: 0000000000000000
[    1.026492] R13: 0000000000000008 R14: 0000000000000003 R15: 00007ff226339010
[    1.047440] Kernel Offset: 0xd000000 from 0xffffffff81000000 (relocation range: 0xffffffff80000000-0xffffffffbfffffff)
[    1.048878] Rebooting in 1 seconds..
libguestfs: child_cleanup: 0xcfef70: child process died



Version-Release number of selected component (if applicable):


How reproducible:
It no longer works

Steps to Reproduce:
1. Update to libvirt 3.5
2. Run virt-customize
3.

Actual results:
Customization fails

Expected results:
Customization succeeds

Additional info:
Comment 1 Richard W.M. Jones 2017-07-12 16:51:47 EDT
This is actually a problem in supermin and/or the kernel, see
bug 1470157.

*** This bug has been marked as a duplicate of bug 1470157 ***

Note You need to log in before you can comment on or make changes to this bug.