Bug 1470167 - Unable to read Gnocchi measures from Heat
Summary: Unable to read Gnocchi measures from Heat
Keywords:
Status: CLOSED DUPLICATE of bug 1470134
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-gnocchi
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Pradeep Kilambi
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-07-12 13:30 UTC by rlopez
Modified: 2017-07-12 14:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-12 14:31:02 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description rlopez 2017-07-12 13:30:13 UTC
When Heat creates resources, metrics, (Ceilometer) measures (Gnocchi) and an alarm (Aodh), the alarms are unable to retrieve the measures to check because the user who owns the alarm does not have permission to read the measures.

Below is the query being used. 

https://github.com/markllama/openshift-on-openstack/blob/gnocchi-alarms/openshift.yaml#L787-L840

Comment 2 Mehdi ABAAKOUK 2017-07-12 14:31:02 UTC

*** This bug has been marked as a duplicate of bug 1470134 ***


Note You need to log in before you can comment on or make changes to this bug.