Bug 1470134 - Unprivileged user can't access to its Gnocchi resources created by Ceilometer
Unprivileged user can't access to its Gnocchi resources created by Ceilometer
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-aodh (Show other bugs)
10.0 (Newton)
Unspecified Unspecified
high Severity high
: z4
: 10.0 (Newton)
Assigned To: Mehdi ABAAKOUK
Sasha Smolyak
: Triaged, ZStream
: 1470167 1471234 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-12 08:33 EDT by Mehdi ABAAKOUK
Modified: 2017-09-10 17:31 EDT (History)
14 users (show)

See Also:
Fixed In Version: openstack-aodh-3.0.3-1.el7ost
Doc Type: Bug Fix
Doc Text:
Alarm created with unprivileged user cannot retrieve statistics from Gnocchi. This version fixes that. Any alarms created before this release must be updated or recreated to pick up this fix.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-06 13:06:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1703824 None None None 2017-07-12 08:35 EDT
OpenStack gerrit 482947 None None None 2017-07-12 08:36 EDT
OpenStack gerrit 483439 None None None 2017-07-13 11:30 EDT
RDO 7638 None None None 2017-07-13 11:30 EDT

  None (edit)
Description Mehdi ABAAKOUK 2017-07-12 08:33:03 EDT
Description of problem:

https://bugs.launchpad.net/aodh/+bug/1703824
Comment 1 Mehdi ABAAKOUK 2017-07-12 08:35:20 EDT
When an unprivileged user want to access to Gnocchi resources
created by Ceilometer, that doesn't work because the filter scope
the Gnocchi query to resource owner to the user.

This break Heat + Aodh with trust.
Heat creates Aodh alarm with the user project.
Ceilometer creates resources and metrics in Gnocchi with the service users.

Aodh can't access to the resource of the user to evaluate the alarm.
Comment 2 Mehdi ABAAKOUK 2017-07-12 10:31:02 EDT
*** Bug 1470167 has been marked as a duplicate of this bug. ***
Comment 6 Mehdi ABAAKOUK 2017-07-17 09:49:21 EDT
*** Bug 1471234 has been marked as a duplicate of this bug. ***
Comment 9 Mehdi ABAAKOUK 2017-07-17 10:21:01 EDT
We have also added your use case in upstream testing: https://review.openstack.org/#/c/459659/
Comment 12 Mark Lamourine 2017-07-18 14:12:09 EDT
A first pass indicates that this is successful. We have been able to create a Heat stack on OSP10 with OCP3.4 which scales both up and down when the load on the OCP app nodes is added and removed.
Comment 17 Mark Lamourine 2017-07-19 16:09:33 EDT
For the openshift-heat-templates, the update has been tested with the hotfix using OCP3.4 on OSP10:

https://github.com/redhat-openstack/openshift-on-openstack/pull/374
Comment 24 errata-xmlrpc 2017-09-06 13:06:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2653

Note You need to log in before you can comment on or make changes to this bug.