Bug 1470468 - [virtio-win][qemu-ga-win][upstream] if guest is auto-released after 10s, the following "guest-fsfreeze-freeze" and "guest-fsfreeze-thaw" should not prompt error.
[virtio-win][qemu-ga-win][upstream] if guest is auto-released after 10s, the ...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win (Show other bugs)
7.4
Unspecified Unspecified
medium Severity low
: rc
: ---
Assigned To: Sameeh Jubran
Virtualization Bugs
:
Depends On: 1406271
Blocks: 1473046
  Show dependency treegraph
 
Reported: 2017-07-12 21:52 EDT by xiagao
Modified: 2017-08-16 05:48 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1406271
Environment:
Last Closed: 2017-08-16 05:48:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Sameeh Jubran 2017-07-23 09:24:10 EDT
I have already sent a patch upstream which attempts to fix the issue but the patch was rejected. Either way now I don't believe that we should change this behaviour as the implementation of the Freeze command is limited to 10 seconds due to limitations from Windows, I think that in case that more than 10 seconds has passed since execution of the Freeze command a suitable message should be displayed. The message informs the user that the freeze operation was only to a period of 10 seconds and that the freeze command have passed this time slice of 10 seconds.

This approach gives the user the information needed to decide what needs to do as the freeze/thaw commands usually executed in order to backup the disks of the guest, if the freeze wasn't held, the backed up data may not be accurate and therefore the user should be informed.
Comment 3 Sameeh Jubran 2017-08-13 12:17:42 EDT
Can you please reply to my comment above? can we close this?
Comment 4 xiagao 2017-08-13 20:08:35 EDT
(In reply to Sameeh Jubran from comment #2)
> I have already sent a patch upstream which attempts to fix the issue but the
> patch was rejected. Either way now I don't believe that we should change
> this behaviour as the implementation of the Freeze command is limited to 10
> seconds due to limitations from Windows, I think that in case that more than
> 10 seconds has passed since execution of the Freeze command a suitable
> message should be displayed. The message informs the user that the freeze
> operation was only to a period of 10 seconds and that the freeze command
> have passed this time slice of 10 seconds.
> 
> This approach gives the user the information needed to decide what needs to
> do as the freeze/thaw commands usually executed in order to backup the disks
> of the guest, if the freeze wasn't held, the backed up data may not be
> accurate and therefore the user should be informed.

I think it's better to prompt a suitable message to inform user that file systems are released after 10s.

1)Freeze guest filesystem.
   {"execute":"guest-fsfreeze-freeze"}
   {"return": 2}
   {"execute":"guest-fsfreeze-status"}        
   {"return": "frozen"}

2)after >10s, thaw guest
   {"execute":"guest-fsfreeze-thaw"}
   {"error": {"desc": "couldn't hold writes: fsfreeze is limited up to 10 seconds:  (error: 8004230f)"}}   -----> I think this error info is not friendly, could you modify it with a suitable message ?

Thanks.
Comment 5 Sameeh Jubran 2017-08-14 03:20:49 EDT
(In reply to xiagao from comment #4)
> (In reply to Sameeh Jubran from comment #2)
> > I have already sent a patch upstream which attempts to fix the issue but the
> > patch was rejected. Either way now I don't believe that we should change
> > this behaviour as the implementation of the Freeze command is limited to 10
> > seconds due to limitations from Windows, I think that in case that more than
> > 10 seconds has passed since execution of the Freeze command a suitable
> > message should be displayed. The message informs the user that the freeze
> > operation was only to a period of 10 seconds and that the freeze command
> > have passed this time slice of 10 seconds.
> > 
> > This approach gives the user the information needed to decide what needs to
> > do as the freeze/thaw commands usually executed in order to backup the disks
> > of the guest, if the freeze wasn't held, the backed up data may not be
> > accurate and therefore the user should be informed.
> 
> I think it's better to prompt a suitable message to inform user that file
> systems are released after 10s.
> 
> 1)Freeze guest filesystem.
>    {"execute":"guest-fsfreeze-freeze"}
>    {"return": 2}
>    {"execute":"guest-fsfreeze-status"}        
>    {"return": "frozen"}
> 
> 2)after >10s, thaw guest
>    {"execute":"guest-fsfreeze-thaw"}
>    {"error": {"desc": "couldn't hold writes: fsfreeze is limited up to 10
> seconds:  (error: 8004230f)"}}   -----> I think this error info is not
> friendly, could you modify it with a suitable message ?
This is the message that is currently displayed in upstream and I want to keep this repository identical to upstream, so I really prefer not to change this at all unless it was changed on upstream.

Thanks :)
> 
> Thanks.
Comment 6 xiagao 2017-08-14 03:33:06 EDT
(In reply to Sameeh Jubran from comment #5)
> (In reply to xiagao from comment #4)
> > (In reply to Sameeh Jubran from comment #2)
> > > I have already sent a patch upstream which attempts to fix the issue but the
> > > patch was rejected. Either way now I don't believe that we should change
> > > this behaviour as the implementation of the Freeze command is limited to 10
> > > seconds due to limitations from Windows, I think that in case that more than
> > > 10 seconds has passed since execution of the Freeze command a suitable
> > > message should be displayed. The message informs the user that the freeze
> > > operation was only to a period of 10 seconds and that the freeze command
> > > have passed this time slice of 10 seconds.
> > > 
> > > This approach gives the user the information needed to decide what needs to
> > > do as the freeze/thaw commands usually executed in order to backup the disks
> > > of the guest, if the freeze wasn't held, the backed up data may not be
> > > accurate and therefore the user should be informed.
> > 
> > I think it's better to prompt a suitable message to inform user that file
> > systems are released after 10s.
> > 
> > 1)Freeze guest filesystem.
> >    {"execute":"guest-fsfreeze-freeze"}
> >    {"return": 2}
> >    {"execute":"guest-fsfreeze-status"}        
> >    {"return": "frozen"}
> > 
> > 2)after >10s, thaw guest
> >    {"execute":"guest-fsfreeze-thaw"}
> >    {"error": {"desc": "couldn't hold writes: fsfreeze is limited up to 10
> > seconds:  (error: 8004230f)"}}   -----> I think this error info is not
> > friendly, could you modify it with a suitable message ?
> This is the message that is currently displayed in upstream and I want to
> keep this repository identical to upstream, so I really prefer not to change
> this at all unless it was changed on upstream.
> 
> Thanks :)
> > 
> > Thanks.


Get it, thanks for explaination. Further confirm with you, in comment 2 you mean you sent a patch upstream which is aboout *displaying a suitable message about this issue*, but it's rejecked, yes ?
Comment 7 Sameeh Jubran 2017-08-14 03:51:06 EDT
(In reply to xiagao from comment #6)
> (In reply to Sameeh Jubran from comment #5)
> > (In reply to xiagao from comment #4)
> > > (In reply to Sameeh Jubran from comment #2)
> > > > I have already sent a patch upstream which attempts to fix the issue but the
> > > > patch was rejected. Either way now I don't believe that we should change
> > > > this behaviour as the implementation of the Freeze command is limited to 10
> > > > seconds due to limitations from Windows, I think that in case that more than
> > > > 10 seconds has passed since execution of the Freeze command a suitable
> > > > message should be displayed. The message informs the user that the freeze
> > > > operation was only to a period of 10 seconds and that the freeze command
> > > > have passed this time slice of 10 seconds.
> > > > 
> > > > This approach gives the user the information needed to decide what needs to
> > > > do as the freeze/thaw commands usually executed in order to backup the disks
> > > > of the guest, if the freeze wasn't held, the backed up data may not be
> > > > accurate and therefore the user should be informed.
> > > 
> > > I think it's better to prompt a suitable message to inform user that file
> > > systems are released after 10s.
> > > 
> > > 1)Freeze guest filesystem.
> > >    {"execute":"guest-fsfreeze-freeze"}
> > >    {"return": 2}
> > >    {"execute":"guest-fsfreeze-status"}        
> > >    {"return": "frozen"}
> > > 
> > > 2)after >10s, thaw guest
> > >    {"execute":"guest-fsfreeze-thaw"}
> > >    {"error": {"desc": "couldn't hold writes: fsfreeze is limited up to 10
> > > seconds:  (error: 8004230f)"}}   -----> I think this error info is not
> > > friendly, could you modify it with a suitable message ?
> > This is the message that is currently displayed in upstream and I want to
> > keep this repository identical to upstream, so I really prefer not to change
> > this at all unless it was changed on upstream.
> > 
> > Thanks :)
> > > 
> > > Thanks.
> 
> 
> Get it, thanks for explaination. Further confirm with you, in comment 2 you
> mean you sent a patch upstream which is aboout *displaying a suitable
> message about this issue*, but it's rejecked, yes ?
Not exactly, the patch that I have sent would eliminate the message at all, however I think I can try and send a patch upstream which attempts to make the message more user friendly, but I don't think that this BZ is severe at all or even that it is needed. Please refer to the following BZ, it discusses the same issue:
https://bugzilla.redhat.com/show_bug.cgi?id=1021913
Comment 8 Sameeh Jubran 2017-08-16 05:48:11 EDT
I am closing this issue.

Note You need to log in before you can comment on or make changes to this bug.