Bug 1470495 - gluster volume status --xml fails when there are 100 volumes
gluster volume status --xml fails when there are 100 volumes
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
3.8
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Atin Mukherjee
: Triaged
Depends On: 1467841 1470488
Blocks: 1467807 glusterfs-3.8.15
  Show dependency treegraph
 
Reported: 2017-07-13 00:31 EDT by Atin Mukherjee
Modified: 2017-10-03 10:20 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.8.15
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1470488
Environment:
Last Closed: 2017-08-29 06:19:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Worker Ant 2017-07-13 00:32:17 EDT
REVIEW: https://review.gluster.org/17766 (cli/xml: fix return handling) posted (#1) for review on release-3.8 by Atin Mukherjee (amukherj@redhat.com)
Comment 2 Atin Mukherjee 2017-07-13 00:35:59 EDT
Description of problem:

when there are large number of volumes in my case 100 volumes, gluster v status --xml command fails

Version-Release number of selected component (if applicable):
release-3.8

How reproducible:

100%

Steps to Reproduce:
1. create & start 100 volume
2. execure gluster v status --xml

Actual results:

[root@dhcp46-22 ~]# gluster v status all clients --xml
[root@dhcp46-22 ~]# echo $?
92
Comment 3 Worker Ant 2017-08-10 12:45:33 EDT
COMMIT: https://review.gluster.org/17766 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit b7b13c8cd295fa2e9fba9cc77211e576469e9581
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Wed Jul 5 14:58:50 2017 +0530

    cli/xml: fix return handling
    
    The return code of xmlTextWriter* APIs says it returns either the bytes
    written (may be 0 because of buffering) or -1 in case of error. Now if the
    volume of the xml data payload is not huge then most of the time the
    data to be written gets buffered, however when this grows sometimes this
    APIs will return the total number of bytes written and then it becomes
    absolutely mandatory that every such call is followed by
    XML_RET_CHECK_AND_GOTO otherwise we may end up returning a non zero ret
    code which would result into the overall xml generation to fail.
    
    >Reviewed-on: https://review.gluster.org/17702
    >Smoke: Gluster Build System <jenkins@build.gluster.org>
    >Reviewed-by: Amar Tumballi <amarts@redhat.com>
    >CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    >Reviewed-by: Gaurav Yadav <gyadav@redhat.com>
    
    Change-Id: I02ee7076e1d8c26cf654d3dc3e77b1eb17cbdab0
    BUG: 1470495
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: https://review.gluster.org/17766
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Samikshan Bairagya <samikshan@gmail.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 4 Jiffin 2017-08-29 06:19:53 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.15, please open a new bug report.

glusterfs-3.8.15 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] blah
[2] https://www.gluster.org/pipermail/gluster-users/
Comment 5 Niels de Vos 2017-10-03 10:20:07 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.15, please open a new bug report.

glusterfs-3.8.15 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2017-August/000080.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.