Bug 1470740 - adb does not reckognize connected devices
Summary: adb does not reckognize connected devices
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: android-tools
Version: 27
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Ivan Afonichev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1489765 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-07-13 14:33 UTC by lukasz.danko
Modified: 2018-07-03 16:51 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-03-06 17:29:30 UTC


Attachments (Terms of Use)

Description lukasz.danko 2017-07-13 14:33:16 UTC
Description of problem:

adc does not see connected devices,
'adb devices -l' return nothing


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Connect android device
2. call adb commadn like 'adb devices -l'
3. no devices found

Actual results:
no devices found

Expected results:
found connected device

Additional info:
Replacing adb from android-tools package with adb from current adnroid sdk fixed the problem.

Comment 1 Fabrice Bellet 2017-08-03 08:08:58 UTC
I confirm the problem with version 20170311gite7195be7725a shipped in Fedora 26, with a Samsung S3 running replicant 6. The log file indicates repeated messages like this one :

Aug 02 23:06:39 localhost kernel: usb 1-1.2: usbfs: process 24859 (device poll) did not claim interface 1 before use
Aug 02 23:06:39 localhost kernel: usb 1-1.2: USB disconnect, device number 82 
Aug 02 23:06:39 localhost kernel: usb 1-1.2: new high-speed USB device number 83 using ehci-pci
Aug 02 23:06:39 localhost kernel: usb 1-1.2: New USB device found, idVendor=04e8, idProduct=6860
Aug 02 23:06:39 localhost kernel: usb 1-1.2: New USB device strings: Mfr=2, Product=3, SerialNumber=4
Aug 02 23:06:39 localhost kernel: usb 1-1.2: Product: GT-I9300
Aug 02 23:06:39 localhost kernel: usb 1-1.2: Manufacturer: samsung
Aug 02 23:06:39 localhost kernel: usb 1-1.2: SerialNumber: xxxxxxxxxxxxxxx
Aug 02 23:06:40 localhost kernel: usb 1-1.2: reset high-speed USB device number 83 using ehci-pci
Aug 02 23:06:40 localhost kernel: usb 1-1.2: usbfs: process 24859 (device poll) did not claim interface 1 before use
Aug 02 23:06:40 localhost kernel: usb 1-1.2: USB disconnect, device number 83 
Aug 02 23:06:40 localhost kernel: usb 1-1.2: new high-speed USB device number 84 using ehci-pci
Aug 02 23:06:40 localhost kernel: usb 1-1.2: New USB device found, idVendor=04e8, idProduct=6860
Aug 02 23:06:40 localhost kernel: usb 1-1.2: New USB device strings: Mfr=2, Product=3, SerialNumber=4
Aug 02 23:06:40 localhost kernel: usb 1-1.2: Product: GT-I9300
Aug 02 23:06:40 localhost kernel: usb 1-1.2: Manufacturer: samsung
Aug 02 23:06:40 localhost kernel: usb 1-1.2: SerialNumber: xxxxxxxxxxxxxxx
Aug 02 23:06:40 localhost kernel: usb 1-1.2: reset high-speed USB device number 84 using ehci-pci

Reverting to version 20160327 fixes this problem.

Comment 2 Fabrice Bellet 2017-08-03 12:10:00 UTC
I'd suggest to apply upstream commit 5d002b8d6. It fixes the bug for me. Commit b5e11415d9fd from the same author may be needed too, as suggested in the first commit message, but for these usb repeated disconnections, _only_ commit 5d002b8d6 is required for me.

Comment 3 agents 2017-08-06 23:13:31 UTC
I had problems connecting to my Samsung Tab S2 under Centos 7, although I can see the device ID it always reports offline.

Note that I need to launch adb as root, if I launch it as a regular user the device ID is always reported as a series of ?.

Comment 4 agents 2017-08-06 23:14:47 UTC
Please add to EPEL for Centos 6 and Centos 7 as well.

Comment 5 Anatolii Vorona 2017-09-10 15:51:37 UTC
*** Bug 1489765 has been marked as a duplicate of this bug. ***

Comment 6 flyingOwl 2018-01-27 10:12:25 UTC
I have the same problem on Fedora 27. My Samsung Galaxy device is not recognized by adb with android-tools-20170311gite7195be7725a-4.fc27, although it shows up in lsusb and in the dmesg log.

With android-tools-20160327git3761365735de-2 however, everything is working without problems.

Comment 7 Bastien Nocera 2018-02-27 18:03:39 UTC
I'm having the same problem, with the adb daemon resetting the USB device constantly.

working:
android-tools-20160327git3761365735de-2.fc25.x86_64

not working:
android-tools-20170311gite7195be7725a-6.fc28
android-tools-20170311gite7195be7725a-4.fc27
android-tools-20170311gite7195be7725a-1.fc27

I didn't test the versions in between, I'm guessing they're broken as well. To reproduce, I removed gvfs-mtp, and made sure no "gvfs-mtp-volume-monitor" was running. Killed all existing "adb" daemons, and ran "adb devices" as root.

You can then see the USB resets happening either in the journal, or in "udevadm monitor".

Comment 8 Fedora Update System 2018-02-27 18:36:28 UTC
android-tools-20170311gite7195be7725a-5.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-ad3b664827

Comment 9 Bastien Nocera 2018-02-28 12:27:11 UTC
Let me know if you need an F26 version as well, and I'll backport the changes.

Comment 10 Fedora Update System 2018-02-28 18:09:11 UTC
android-tools-20170311gite7195be7725a-5.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-ad3b664827

Comment 11 Fedora Update System 2018-03-06 17:29:30 UTC
android-tools-20170311gite7195be7725a-5.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 flyingOwl 2018-03-09 16:09:07 UTC
I installed the new version 20170311gite7195be7725a-5.fc27, but the problem is still there. Adb does not recognize my device.

dmesg output:
[ 4908.554810] usb 3-2: new high-speed USB device number 22 using xhci_hcd
[ 4908.686598] usb 3-2: New USB device found, idVendor=04e8, idProduct=681c
[ 4908.686602] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 4908.686604] usb 3-2: Product: SAMSUNG_Android
[ 4908.686606] usb 3-2: Manufacturer: SAMSUNG
[ 4908.686608] usb 3-2: SerialNumber: 6xxxxxxxxxxx
[ 4908.691812] cdc_acm 3-2:3.0: ttyACM0: USB ACM device
[ 4908.692550] usb-storage 3-2:3.2: USB Mass Storage device detected
[ 4908.692786] scsi host5: usb-storage 3-2:3.2
[ 4909.710701] scsi 5:0:0:0: Direct-Access     SAMSUNG  GT-I5800 Card    0000 PQ: 0 ANSI: 2
[ 4909.711469] sd 5:0:0:0: Attached scsi generic sg2 type 0
[ 4909.759020] sd 5:0:0:0: [sdc] Attached SCSI removable disk

lsusb output:
Bus 003 Device 022: ID 04e8:681c Samsung Electronics Co., Ltd Galaxy Portal/Spica/S

And no matter how often and in what order I reset/restart adb or reconnect the device, the device won't show up with "adb devices -l".
Right after I remove the new android-tools package and re-install the older version (android-tools-20160327git3761365735de-2) it works:

$ adb devices -l
List of devices attached
adb server version (39) doesn't match this client (35); killing...
* daemon started successfully *
6xxxxxxxxxxx           device usb:3-2
$ adb shell
~ #

Comment 13 Solomon Peachy 2018-06-22 17:17:37 UTC
This bug also affects F28: android-tools-20170311gite7195be7725a-6.fc28 

(f27's package has the patch, and f29's package has the patch, but f28 is MIA)

Comment 14 Fedora Update System 2018-06-25 09:25:23 UTC
android-tools-20170311gite7195be7725a-7.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-2a7ce2bd9c

Comment 15 Fedora Update System 2018-06-26 18:23:20 UTC
android-tools-20170311gite7195be7725a-7.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-2a7ce2bd9c

Comment 16 Fedora Update System 2018-07-03 16:51:15 UTC
android-tools-20170311gite7195be7725a-7.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.