Bug 1489765 - adb not work g_simple_async_result_propagate_error
Summary: adb not work g_simple_async_result_propagate_error
Keywords:
Status: CLOSED DUPLICATE of bug 1470740
Alias: None
Product: Fedora
Classification: Fedora
Component: android-tools
Version: 26
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Ivan Afonichev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-08 10:21 UTC by Anatolii Vorona
Modified: 2017-09-10 15:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-10 15:51:37 UTC
Type: Bug


Attachments (Terms of Use)

Description Anatolii Vorona 2017-09-08 10:21:24 UTC
Description of problem:
Adb not work.

Version-Release number of selected component (if applicable):
F26: 
libgdata-0.17.8-1.fc26.x86_64
glib2-2.52.3-1.fc26.x86_64
libmtp-1.1.13-1.fc26.x86_64


How reproducible:
Install F26, android tools, systemctl enable/start adb, and connect device with enabled USB debugging.

Actual results:

>> Sep 08 11:37:53 probook.localdomain kernel: usb 2-2: new high-speed USB device number 125 using xhci_hcd
>> Sep 08 11:37:54 probook.localdomain kernel: usb 2-2: New USB device found, idVendor=22b8, idProduct=2e76
>> Sep 08 11:37:54 probook.localdomain kernel: usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
>> Sep 08 11:37:54 probook.localdomain kernel: usb 2-2: Product: XT1635-02
>> Sep 08 11:37:54 probook.localdomain kernel: usb 2-2: Manufacturer: motorola
>> Sep 08 11:37:54 probook.localdomain kernel: usb 2-2: SerialNumber: ZY223N9MNZ
>> Sep 08 11:37:54 probook.localdomain gnome-shell[1817]: invalid cast from 'GTask' to 'GSimpleAsyncResult'
>> Sep 08 11:37:54 probook.localdomain gnome-shell[1817]: g_simple_async_result_propagate_error: assertion 'G_IS_SIMPLE_ASYNC_RESULT (simple)' failed
>> Sep 08 11:37:54 probook.localdomain kernel: usb 2-2: USB disconnect, device number 125
>> Sep 08 11:37:58 probook.localdomain kernel: usb 2-2: new high-speed USB device number 126 using xhci_hcd
>> Sep 08 11:37:58 probook.localdomain kernel: usb 2-2: New USB device found, idVendor=22b8, idProduct=2e76
>> Sep 08 11:37:58 probook.localdomain kernel: usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
>> Sep 08 11:37:58 probook.localdomain kernel: usb 2-2: Product: XT1635-02
>> Sep 08 11:37:58 probook.localdomain kernel: usb 2-2: Manufacturer: motorola
>> Sep 08 11:37:58 probook.localdomain kernel: usb 2-2: SerialNumber: ZY223N9MNZ
>> Sep 08 11:37:58 probook.localdomain gnome-shell[1817]: invalid cast from 'GTask' to 'GSimpleAsyncResult'
>> Sep 08 11:37:58 probook.localdomain gnome-shell[1817]: g_simple_async_result_propagate_error: assertion 'G_IS_SIMPLE_ASYNC_RESULT (simple)' failed

>> $ adb devices
>> List of devices attached
>> <no devices>

Expected results:

On Fedora 25, the same phone:
libgdata-0.17.8-1.fc25.x86_64
glib2-2.50.3-1.fc25.x86_64
libmtp-1.1.13-1.fc25.x86_64

>>  Sep 08 11:43:49 desktop.local kernel: usb 1-13: new high-speed USB device number 8 using xhci_hcd
>>  Sep 08 11:43:49 desktop.local kernel: usb 1-13: New USB device found, idVendor=22b8, idProduct=2e76
>>  Sep 08 11:43:49 desktop.local kernel: usb 1-13: New USB device strings: Mfr=1, Product=2, SerialNumber=3
>>  Sep 08 11:43:49 desktop.local kernel: usb 1-13: Product: XT1635-02
>>  Sep 08 11:43:49 desktop.local kernel: usb 1-13: Manufacturer: motorola
>>  Sep 08 11:43:49 desktop.local kernel: usb 1-13: SerialNumber: ZY223N9MNZ
>>  Sep 08 11:43:49 desktop.local gvfsd[2670]: Device 0 (VID=22b8 and PID=2e76) is a Motorola Moto G (ID1).
>>  Sep 08 11:43:49 desktop.local gvfsd[2670]: Error 1: Get Storage information failed.
>>  Sep 08 11:43:49 desktop.local tracker-miner-f[2947]: Could not find parent node for URI:'mtp://[usb:001,008]/'
>>  Sep 08 11:43:49 desktop.local tracker-miner-f[2947]: NOTE: URI theme may be outside scheme expected, for example, expecting 'file://' when given 'http://' prefix.
>>  Sep 08 11:43:49 desktop.local tracker-miner-f[2947]: Could not find parent node for URI:'mtp://[usb:001,008]/'
>>  Sep 08 11:43:49 desktop.local tracker-miner-f[2947]: NOTE: URI theme may be outside scheme expected, for example, expecting 'file://' when given 'http://' prefix.
>>  Sep 08 11:43:49 desktop.local tracker-miner-f[2947]: Could not set mount point in database 'urn:nepomuk:datasource:981db91863debd77112da053b7ce36ad', GDBus.Error:org.freedesktop.Tracker1.SparqlError.Internal: UNIQUE constraint failed: nie:DataObject.nie:url (strerror of errno (not necessarily related): Resource temporarily unavailable)
>>  Sep 08 11:43:49 desktop.local tracker-miner-f[2947]: Could not set mount point in database 'urn:nepomuk:datasource:0ff9130fe47a1021c9f13773c891ad1d', GDBus.Error:org.freedesktop.Tracker1.SparqlError.Internal: UNIQUE constraint failed: nie:DataObject.nie:url (strerror of errno (not necessarily related): Resource temporarily unavailable)
>>  Sep 08 11:43:49 desktop.local dbus-daemon[2594]: [session uid=1000 pid=2594] Activating service name='org.gnome.Shell.HotplugSniffer' requested by ':1.21' (uid=1000 pid=2697 comm="/usr/bin/gnome-shell " label="unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023")
>>  Sep 08 11:43:49 desktop.local dbus-daemon[2594]: [session uid=1000 pid=2594] Successfully activated service 'org.gnome.Shell.HotplugSniffer'

>> $ adb devices
>> List of devices attached
>> ZY223N9MNZ      device

Additional info:

Comment 1 Bastien Nocera 2017-09-08 11:08:29 UTC
Why is this filed against libgdata? I have no idea...

Did you read and install the /usr/share/doc/android-tools/51-android.rules file as mentioned the top of it?

Comment 2 Anatolii Vorona 2017-09-08 11:22:49 UTC
F26: android-tools-20170311gite7195be7725a-2.fc26.x86_64
F25: android-tools-20160327git3761365735de-2.fc25.x86_64

They both have same files, md5:
cf553937953c5879b08267bcf335a69a  /usr/share/doc/android-tools/51-android.rules

Comment 3 Anatolii Vorona 2017-09-08 11:27:59 UTC
> Why is this filed against libgdata? I have no idea...

Because errors are related to libgdata:
>> invalid cast from 'GTask' to 'GSimpleAsyncResult'
>> g_simple_async_result_propagate_error: assertion 'G_IS_SIMPLE_ASYNC_RESULT (simple)' failed

Comment 4 Anatolii Vorona 2017-09-10 15:51:37 UTC
Downgrade to android-tools-20160327git3761365735de-2.fc25.x86_64.rpm fixes the problem for me.

*** This bug has been marked as a duplicate of bug 1470740 ***


Note You need to log in before you can comment on or make changes to this bug.