Bug 147082 - Evince does not recognize and open compressed PS-files
Evince does not recognize and open compressed PS-files
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Marco Pesenti Gritti
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-04 04:34 EST by Joachim Frieben
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-08 05:03:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2005-02-04 04:34:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20050109 Epiphany/1.5.5

Description of problem:
Evince is unable to uncompress and open *ps.gz and *ps.bz2 files.

Version-Release number of selected component (if applicable):
evince-0.1.2-1

How reproducible:
Always

Steps to Reproduce:
1. Open a compressed PS-file by means of "evince".


Actual Results:  Evince issues "Unhandled MIME type:
'application/x-gzpostscript'" and "Unhandled MIME type:
'application/x-bzip'" respectively.

Expected Results:  Evince should have called the appropriate helper
application and displayed the uncompressed PS-file.

Additional info:

The correct behaviour is common standard for "ggv".
Comment 1 Marco Pesenti Gritti 2005-02-04 11:23:24 EST
Implemented for gz. For bz I think it would require a mime type to be
added to the freedesktop spec.
Are bzipped ps common at all or is it a ggv only feature?
Comment 2 Joachim Frieben 2005-02-08 04:12:16 EST
As "bzip2" is going to succeed "gzip" in the middle/long term, the
corresponding options is certainly useful. Since "ggv" is offering
this possibility, I do keep all of my PS files compressed with "bzip2"
which results in extremely reduced file sizes. Moreover, it's really
only a minor tweak to call "bzip2" instead of "gzip" as soon as the
associated suffix is detected. So, if "gzip" decompression is already
implemented, no reason not to do so for "bzip2".
Comment 3 Marco Pesenti Gritti 2005-02-08 05:03:06 EST
>as soon as the associated suffix is detected

Mime detection in evince is done through the freedesktop spec. I dont
think I feel to argue to add x-bzpostscript there. Feel free to do it
though and reopen this bug.

You can post a request to:
https://bugs.freedesktop.org/

shared-mime-info module

Note You need to log in before you can comment on or make changes to this bug.