Bug 1470876 - Darktable aborts immediately on launch due to opencl
Darktable aborts immediately on launch due to opencl
Status: CLOSED DUPLICATE of bug 1468392
Product: Fedora
Classification: Fedora
Component: darktable (Show other bugs)
26
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Edouard Bourguignon
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-13 18:14 EDT by Daniel Berrange
Modified: 2017-07-18 14:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-14 06:36:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Stack trace of crash (2.79 KB, text/plain)
2017-07-13 18:14 EDT, Daniel Berrange
no flags Details

  None (edit)
Description Daniel Berrange 2017-07-13 18:14:09 EDT
Created attachment 1297894 [details]
Stack trace of crash

Description of problem:

$ darktable
X server found. dri2 connection failed! 
X server found. dri2 connection failed! 
X server found. dri2 connection failed! 
X server found. dri2 connection failed! 
X server found. dri2 connection failed! 
X server found. dri2 connection failed! 
darktable: /usr/include/llvm/Support/Casting.h:236: typename llvm::cast_retty<X, Y*>::ret_type llvm::cast(Y*) [with X = llvm::CompositeType; Y = llvm::Type; typename llvm::cast_retty<X, Y*>::ret_type = llvm::CompositeType*]: Assertion `isa<X>(Val) && "cast<Ty>() argument of incompatible type!"' failed.
Aborted (core dumped)


Passing the --disable-opencl argument on the CLI allows it to start, but this is not a good user experiance for people.

I'm using defualt GNOME on Wayland desktop, 

The cltest program similarly crashes

$ darktable-cltest 
[opencl_init] opencl related configuration options:
[opencl_init] 
[opencl_init] opencl: 1
[opencl_init] opencl_library: ''
[opencl_init] opencl_memory_requirement: 768
[opencl_init] opencl_memory_headroom: 300
[opencl_init] opencl_device_priority: '*/!0,*/*/*'
[opencl_init] opencl_size_roundup: 16
[opencl_init] opencl_async_pixelpipe: 0
[opencl_init] opencl_synch_cache: 0
[opencl_init] opencl_number_event_handles: 25
[opencl_init] opencl_micro_nap: 1000
[opencl_init] opencl_use_pinned_memory: 0
[opencl_init] opencl_use_cpu_devices: 0
[opencl_init] opencl_avoid_atomics: 0
[opencl_init] opencl_enable_markesteijn: 1
[opencl_init] 
[opencl_init] could not find opencl runtime library 'libOpenCL'
[opencl_init] could not find opencl runtime library 'libOpenCL.so'
[opencl_init] found opencl runtime library 'libOpenCL.so.1'
[opencl_init] opencl library 'libOpenCL.so.1' found on your system and loaded
X server found. dri2 connection failed! 
X server found. dri2 connection failed! 
X server found. dri2 connection failed! 
X server found. dri2 connection failed! 
X server found. dri2 connection failed! 
X server found. dri2 connection failed! 
darktable-cltest: /usr/include/llvm/Support/Casting.h:236: typename llvm::cast_retty<X, Y*>::ret_type llvm::cast(Y*) [with X = llvm::CompositeType; Y = llvm::Type; typename llvm::cast_retty<X, Y*>::ret_type = llvm::CompositeType*]: Assertion `isa<X>(Val) && "cast<Ty>() argument of incompatible type!"' failed.
Aborted (core dumped)


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Daniel Berrange 2017-07-13 18:15:07 EDT
Sorry, hit submit too soon - version is darktable-2.2.5-2.fc26.x86_64.  Previously on Fedora 25 it worked fine.
Comment 2 Germano Massullo 2017-07-14 02:52:53 EDT

*** This bug has been marked as a duplicate of bug 1468392 ***
Comment 3 Daniel Berrange 2017-07-14 04:23:25 EDT
Re-opening because expecting people to just uninstall beignet is not disoverable. Darktable RPM should add a conflicts beignet if its incompatible with it..
Comment 4 Germano Massullo 2017-07-14 04:43:46 EDT
(In reply to Daniel Berrange from comment #3)
> Re-opening because expecting people to just uninstall beignet is not
> disoverable. Darktable RPM should add a conflicts beignet if its
> incompatible with it..

darktable is not incompatible with it, it is beignet that is poorly developed and tested.
I am trying to figure out why it is shipped by default on Fedora ISOs
https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/PZSRYVKOW4JA675S5ZQY7EU3C4WLHPDI/

Anyway, I am considering to add Conflicts: beignet into darktable spec file
Comment 5 Daniel Berrange 2017-07-14 06:36:51 EDT
I'm remarking this as a dup of the beignet bug, since a beignet update was just issued that solves this problem satisfactorily for me.

*** This bug has been marked as a duplicate of bug 1468392 ***
Comment 6 Germano Massullo 2017-07-14 06:40:15 EDT
(In reply to Daniel Berrange from comment #5)
> I'm remarking this as a dup of the beignet bug, since a beignet update was
> just issued that solves this problem satisfactorily for me.
> 
> *** This bug has been marked as a duplicate of bug 1468392 ***

Yes, after a discussion in #fedora-devel, a new beignet update has been submitted to let it work with llvm update
https://bodhi.fedoraproject.org/updates/FEDORA-2017-3aa9e1fe13
So, definitely not a darktable problem

Note You need to log in before you can comment on or make changes to this bug.