Bug 1471198 - [3.6] DNSSearchForming: Event Spam
[3.6] DNSSearchForming: Event Spam
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Derek Carr
Weihua Meng
:
: 1471197 (view as bug list)
Depends On:
Blocks: 1473352
  Show dependency treegraph
 
Reported: 2017-07-14 12:16 EDT by Eric Paris
Modified: 2017-08-16 15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1473352 (view as bug list)
Environment:
Last Closed: 2017-08-10 01:31:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Paris 2017-07-14 12:16:05 EDT
I see lots of events like:

Pod Warning   DNSSearchForming   kubelet, ip-172-31-52-130.ec2.internal   Found and omitted duplicated dns domain in host search line: 'cluster.local' during merging with cluster dns domains

1 pod is showing these events more than once per second.

Do we need these at all?
Should they be rate limited? (are they?)
Is this a misconfiguration of some sort?
Comment 1 Eric Paris 2017-07-14 12:19:16 EDT
*** Bug 1471197 has been marked as a duplicate of this bug. ***
Comment 2 Derek Carr 2017-07-17 10:37:52 EDT
Upstream PR:
https://github.com/kubernetes/kubernetes/pull/48960
Comment 3 Derek Carr 2017-07-17 10:42:09 EDT
The rate limiting work we are carrying in Origin pending:
https://github.com/kubernetes/kubernetes/pull/47367

will make a major improvement to the rate of events in this case.

This event serves the cluster operator more than the cluster end-user.

Agree it should be removed.
Comment 4 Derek Carr 2017-07-17 16:12:10 EDT
Origin PR:
https://github.com/openshift/origin/pull/15246
Comment 5 Derek Carr 2017-07-19 15:28:09 EDT
Origin 3.6 PR:
https://github.com/openshift/origin/pull/15350
Comment 6 Derek Carr 2017-07-20 11:03:09 EDT
merged in 3.6.
Comment 8 Weihua Meng 2017-07-24 22:14:41 EDT
Verified on openshift v3.6.169
Fixed.

No "DNSSearchForming" message in events any more.
Comment 10 errata-xmlrpc 2017-08-10 01:31:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.