Bug 1471232 - After upgrading from 4.2 to 4.5 AWS EBS storage is not discovered
After upgrading from 4.2 to 4.5 AWS EBS storage is not discovered
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.8.0
All All
high Severity high
: GA
: 5.9.0
Assigned To: Daniel Berger
Matouš Mojžíš
ec2:ebs:upgrade
: TestOnly, ZStream
Depends On:
Blocks: 1480629 1480630
  Show dependency treegraph
 
Reported: 2017-07-14 14:51 EDT by Ryan Spagnola
Modified: 2018-03-06 10:41 EST (History)
11 users (show)

See Also:
Fixed In Version: 5.9.0.1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1480629 1480630 (view as bug list)
Environment:
Last Closed: 2018-03-06 10:41:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: AWS


Attachments (Terms of Use)

  None (edit)
Description Ryan Spagnola 2017-07-14 14:51:17 EDT
Description of problem:
Not discovering any AWS EBS storage volumes.   Working within the Same AWS region.   All Server Roles are on except for RHN Mirroring.

Version-Release number of selected component (if applicable):
5.8.0.17

How reproducible:
Repeatedly

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
From Customer:
I increased the memory to 16GB and restarted the Server.  I also did restart of the evmserverd. The first time the system online,  CFME was in a rather hung state.  I had to restart the server a second time and everything came back fine.   I waited awhile for the provider worker to finish the discovery.  Still no Storage.

Yes,  This was upgraded from CF 4.2.  Server was orginally installed around March 2017 at 4.2.  Upgraded to 4.5 last month.   

[2] Ran the commands you requested.  See attached ems.txt and worker.txt 

[3].  I ran the commands you provided.

Loading production environment (Rails 5.0.3)
irb(main):001:0> ManageIQ::Providers::Amazon::CloudManager.all.each { |m| m.ensure_managers }
PostgreSQLAdapter#log_after_checkout, connection_pool: size: 5, connections: 1, in use: 1, waiting_in_queue: 0
=> [#<ManageIQ::Providers::Amazon::CloudManager id: 90000000000001, name: "AWS-eu-west-1-Dev", created_on: "2017-03-17 14:37:23", updated_on: "2017-07-13 18:03:55", guid: "3bef5f80-0b1f-11e7-82ec-0050569e14dd", zone_id: 90000000000002, type: "ManageIQ::Providers::Amazon::CloudManager", api_version: nil, uid_ems: nil, host_default_vnc_port_start: nil, host_default_vnc_port_end: nil, provider_region: "eu-west-1", last_refresh_error: nil, last_refresh_date: "2017-07-13 18:03:55", provider_id: nil, realm: nil, tenant_id: 90000000000001, project: nil, parent_ems_id: nil, subscription: nil, last_metrics_error: nil, last_metrics_update_date: nil, last_metrics_success_date: nil, tenant_mapping_enabled: nil>]
irb(main):002:0>
Comment 2 Daniel Berger 2017-07-19 11:57:02 EDT
The parser uses the aws sdk library to gather all volumes, so this is strange.

Is the customer able to get volume information on the command line? Please try the following command, updating the volume name and/or region as appropriate, and report the output.

aws ec2 describe-volumes --filter Name=tag-key,Values="Name" Name=tag-value,Values="your_volume_name" --region us-west-1
Comment 11 Matouš Mojžíš 2017-12-05 10:58:12 EST
Verified in 5.9.0.11.
Upgraded from 5.7.4.1 to 5.9.0.11 and there are no errors in console and EBS storage manager was added.

Note You need to log in before you can comment on or make changes to this bug.