Bug 1471234 - Unprivileged user can't access to its Gnocchi resources created by Ceilometer
Unprivileged user can't access to its Gnocchi resources created by Ceilometer
Status: CLOSED DUPLICATE of bug 1470134
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-aodh (Show other bugs)
10.0 (Newton)
Unspecified Unspecified
unspecified Severity unspecified
: zstream
: 10.0 (Newton)
Assigned To: Mehdi ABAAKOUK
Sasha Smolyak
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-14 14:57 EDT by david.costakos
Modified: 2017-09-10 17:31 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-17 09:49:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1703824 None None None 2017-07-14 14:57 EDT

  None (edit)
Description david.costakos 2017-07-14 14:57:55 EDT
Description of problem:
When an unprivileged user want to access to Gnocchi resources
created by Ceilometer, that doesn't work because the filter scope
the Gnocchi query to resource owner to the user.  this causes autoscaling templates launched by non-admin users to fail

Version-Release number of selected component (if applicable):
python-aodh-3.0.2-1.el7ost.noarch

How reproducible:
always

Steps to Reproduce:
1.create autoscaling template based on cpu_util metric
2. launch as a user/tenant without admin privileges
3. aodh alarms alwasy report 'insufficient data'

Actual results:
autoscaling templates fail to fuction

Expected results:
autoscaling templates would function

Additional info:
seems covered by launchpad bug 1703824  fixe tested on OSP 10 Newton Z3 from the review and it worked in our lab

Note You need to log in before you can comment on or make changes to this bug.