Bug 1471589 - [abrt] dnfdragora-gui: __shutdown(): updater.py:92:__shutdown:TypeError: 'list' object is not callable
[abrt] dnfdragora-gui: __shutdown(): updater.py:92:__shutdown:TypeError: 'lis...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnfdragora (Show other bugs)
26
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Björn 'besser82' Esser
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:0f5620636b2d8b05b210a1950c5...
:
: 1488113 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-16 22:26 EDT by hkoba
Modified: 2018-01-01 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version: dnfdragora-1.0.1-8.git20171229.24e4647.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-31 16:27:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (748 bytes, text/plain)
2017-07-16 22:26 EDT, hkoba
no flags Details
File: cgroup (289 bytes, text/plain)
2017-07-16 22:26 EDT, hkoba
no flags Details
File: cpuinfo (1.85 KB, text/plain)
2017-07-16 22:26 EDT, hkoba
no flags Details
File: environ (1.42 KB, text/plain)
2017-07-16 22:26 EDT, hkoba
no flags Details
File: mountinfo (3.72 KB, text/plain)
2017-07-16 22:26 EDT, hkoba
no flags Details
File: namespaces (102 bytes, text/plain)
2017-07-16 22:26 EDT, hkoba
no flags Details
File: open_fds (1.02 KB, text/plain)
2017-07-16 22:26 EDT, hkoba
no flags Details

  None (edit)
Description hkoba 2017-07-16 22:26:25 EDT
Description of problem:
Just tried to stop dnfdragora via right click menu.

Version-Release number of selected component:
dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26

Additional info:
reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: __shutdown
exception_type: TypeError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.11.9-300.fc26.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
updater.py:92:__shutdown:TypeError: 'list' object is not callable

Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/pystray/_base.py", line 236, in inner
    callback(self)
  File "/usr/lib/python3.6/site-packages/pystray/_base.py", line 320, in __call__
    return self._action(icon, self)
  File "/usr/lib/python3.6/site-packages/pystray/_base.py", line 414, in wrapper1
    return action(icon)
  File "/usr/lib/python3.6/site-packages/dnfdragora/updater.py", line 92, in __shutdown
    for task in self.__scheduler.queue():
TypeError: 'list' object is not callable

Local variables in innermost frame:
kwargs: (<pystray._gtk.Icon object at 0x7f058f33f6d8>,)
self: <dnfdragora.updater.Updater object at 0x7f05b0e178d0>

Potential duplicate: bug 1453003
Comment 1 hkoba 2017-07-16 22:26:31 EDT
Created attachment 1299588 [details]
File: backtrace
Comment 2 hkoba 2017-07-16 22:26:33 EDT
Created attachment 1299589 [details]
File: cgroup
Comment 3 hkoba 2017-07-16 22:26:34 EDT
Created attachment 1299590 [details]
File: cpuinfo
Comment 4 hkoba 2017-07-16 22:26:35 EDT
Created attachment 1299591 [details]
File: environ
Comment 5 hkoba 2017-07-16 22:26:37 EDT
Created attachment 1299592 [details]
File: mountinfo
Comment 6 hkoba 2017-07-16 22:26:39 EDT
Created attachment 1299593 [details]
File: namespaces
Comment 7 hkoba 2017-07-16 22:26:40 EDT
Created attachment 1299594 [details]
File: open_fds
Comment 8 Fabrício 2017-09-04 07:10:35 EDT
*** Bug 1488113 has been marked as a duplicate of this bug. ***
Comment 9 strasharo2000 2017-10-29 11:30:24 EDT
Similar problem has been detected:

Tried to exit the applet from the tray.

reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: __shutdown
exception_type: TypeError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.5-200.fc26.x86_64
package:        dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26
reason:         updater.py:92:__shutdown:TypeError: 'list' object is not callable
runlevel:       N 5
type:           Python3
uid:            1000
Comment 10 Fedora Update System 2017-12-29 18:21:18 EST
dnfdaemon-0.3.18-5.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06
Comment 11 Fedora Update System 2017-12-29 18:26:46 EST
dnfdaemon-0.3.18-5.fc26 dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b
Comment 12 Fedora Update System 2017-12-30 14:53:38 EST
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06
Comment 13 Fedora Update System 2017-12-30 15:39:25 EST
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b
Comment 14 Fedora Update System 2017-12-31 16:27:11 EST
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2018-01-01 17:10:50 EST
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.