Bug 1471620 - [v2v] No ISO domains are offered, when Install drivers option is chosen
[v2v] No ISO domains are offered, when Install drivers option is chosen
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.8.0
Unspecified Unspecified
unspecified Severity high
: GA
: cfme-future
Assigned To: Martin Betak
Ilanit Stein
rhev:v2v
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-17 01:55 EDT by Ilanit Stein
Modified: 2017-07-17 10:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-17 09:53:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: RHEVM


Attachments (Terms of Use)
no_iso_datastore_for_provider (27.33 KB, image/png)
2017-07-17 01:58 EDT, Ilanit Stein
no flags Details

  None (edit)
Description Ilanit Stein 2017-07-17 01:55:38 EDT
Description of problem:

For v2v, when marking "Install drivers" check box,
a list of ISO datastores should be displayed.
However, though there is an active ISO datastore, in the chosen RHV provider,
Only a "no ISO datastore for provider" appear, instead.

 
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Ilanit Stein 2017-07-17 01:57:27 EDT
Version:
CFME-5.8.1 + added patches for v2v bug, so that Install Drivers, ISO datastore list do not give Script Error.
/ RHV-4.1.3
Comment 3 Ilanit Stein 2017-07-17 01:58 EDT
Created attachment 1299646 [details]
no_iso_datastore_for_provider
Comment 4 Martin Betak 2017-07-17 05:38:50 EDT
Yes this is to give the user an indication he needs to add an ISO domain to the RHV provider in order to be able to choose ISOs. For example as in the cluster listbox you have "--- choose provider first ---" to indicate that this listbox depends on something external.

This is working as intended.
Comment 5 Martin Betak 2017-07-17 08:50:06 EDT
If the ISO domain is indeed added (please make sure it is added to the RHV provider that you *select in the dialog as target*) the ISO list box should say "--- select drivers ISO from list ---" and below a filtered list of ISOs matching the naming convention for installation ISOs
Comment 6 Martin Betak 2017-07-17 09:53:55 EDT
Closing. Based on an offline discussion, the domain was indeed missing.
Comment 7 Ilanit Stein 2017-07-17 10:10:07 EDT
Filed bug 1471830, to have a help message added, that instruct to add ISO data store under Compute>PXE>ISO.

Note You need to log in before you can comment on or make changes to this bug.