Bug 1471651 - wrong kernel-rt dependency
wrong kernel-rt dependency
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs (Show other bugs)
7.4
x86_64 Unspecified
high Severity high
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
V2V
: Regression, ZStream
Depends On:
Blocks: 1473046 1471829
  Show dependency treegraph
 
Reported: 2017-07-17 03:45 EDT by mxie@redhat.com
Modified: 2018-04-10 05:15 EDT (History)
13 users (show)

See Also:
Fixed In Version: libguestfs-1.36.5-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1471829 (view as bug list)
Environment:
Last Closed: 2018-04-10 05:15:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mxie@redhat.com 2017-07-17 03:45:11 EDT
Description of problem:
kernel-rt will be depent during virt-v2v installation

Version-Release number of selected component (if applicable):
virt-v2v-1.36.3-6.el7_4.1
libguestfs-1.36.3-6.el7_4.1

How reproducible:
100%

Steps to Reproduce:
1.Prepare related repo and try to install virt-v2v,but v2v installation can't be finished due to lacking of kernel-rt package
[root@localhost ~]# yum install virt-v2v
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
              : manager
This system is not registered with an entitlement server. You can use subscription-manager to register.
Resolving Dependencies
--> Running transaction check
---> Package virt-v2v.x86_64 1:1.36.3-6.el7_4.1 will be installed
--> Processing Dependency: libguestfs-tools-c = 1:1.36.3-6.el7_4.1 for package: 1:virt-v2v-1.36.3-6.el7_4.1.x86_64
--> Processing Dependency: libguestfs = 1:1.36.3-6.el7_4.1 for package: 1:virt-v2v-1.36.3-6.el7_4.1.x86_64
--> Processing Dependency: libguestfs-winsupport >= 7.2 for package: 1:virt-v2v-1.36.3-6.el7_4.1.x86_64
--> Processing Dependency: OVMF for package: 1:virt-v2v-1.36.3-6.el7_4.1.x86_64
--> Running transaction check
---> Package OVMF.noarch 0:20170228-5.gitc325e41585e3.el7 will be installed
---> Package libguestfs.x86_64 1:1.36.3-6.el7 will be updated
---> Package libguestfs.x86_64 1:1.36.3-6.el7_4.1 will be an update
--> Processing Dependency: kernel-rt for package: 1:libguestfs-1.36.3-6.el7_4.1.x86_64
---> Package libguestfs-tools-c.x86_64 1:1.36.3-6.el7_4.1 will be installed
--> Processing Dependency: /usr/bin/hexedit for package: 1:libguestfs-tools-c-1.36.3-6.el7_4.1.x86_64
---> Package libguestfs-winsupport.x86_64 0:7.2-2.el7 will be installed
--> Processing Dependency: /usr/bin/hexedit for package: 1:libguestfs-tools-c-1.36.3-6.el7_4.1.x86_64
--> Finished Dependency Resolution
Error: Package: 1:libguestfs-tools-c-1.36.3-6.el7_4.1.x86_64 (CI-RHEL7.4-1)
           Requires: /usr/bin/hexedit
Error: Package: 1:libguestfs-1.36.3-6.el7_4.1.x86_64 (CI-RHEL7.4-1)
           Requires: kernel-rt
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest



Actula results:
As above description

Expected results:
there is no kernel-rt package showing during virt-v2v installation


Additional info:
This problem can't be reproduced on virt-v2v/libguestfs-1.36.3-6.el7
Comment 13 kuwei@redhat.com 2017-09-21 08:19:49 EDT
Verify the bug with below builds:
virt-v2v-1.36.6-1.el7.x86_64
libguestfs-1.36.6-1.el7.x86_64
libvirt-3.7.0-2.el7.x86_64
qemu-kvm-rhev-2.9.0-16.el7_4.8.x86_64

Steps:
1.Prepare a new installed physical rhel7.4 machine.
2.Prepare related repo and try to install virt-v2v,like below
# yum install virt-v2v
------------------------
Installing:
 virt-v2v                                        x86_64           1:1.36.6-1.el7                            CI-RHEL7.5-1             12 M
Installing for dependencies:
 OVMF                                            noarch           20170228-5.gitc325e41585e3.el7            CI                      1.5 M
 autogen-libopts                                 x86_64           5.18-5.el7                                beaker-Server            66 k
 gnutls-dane                                     x86_64           3.3.26-9.el7                              beaker-Server            34 k
 gnutls-utils                                    x86_64           3.3.26-9.el7                              beaker-Server           237 k
 hexedit                                         x86_64           1.2.13-5.el7                              beaker-Server            39 k
 hivex                                           x86_64           1.3.10-5.8.el7                            CI                      100 k
 libguestfs                                      x86_64           1:1.36.6-1.el7                            CI-RHEL7.5-1            1.9 M
 libguestfs-tools-c                              x86_64           1:1.36.6-1.el7                            CI-RHEL7.5-1            3.1 M
 libguestfs-winsupport                           x86_64           7.2-2.el7                                 CI                      2.1 M
 libvirt-client                                  x86_64           3.7.0-2.el7                               CI-RHEL7.5-1            440 k
 perl-hivex                                      x86_64           1.3.10-5.8.el7                            CI                       40 k
 scrub                                           x86_64           2.5.2-7.el7                               beaker-Server            41 k
 squashfs-tools                                  x86_64           4.3-0.21.gitaae0aff4.el7                  beaker-Server           101 k
 supermin5                                       x86_64           5.1.16-4.el7                              beaker-Server           550 k
 syslinux                                        x86_64           4.05-13.el7                               beaker-Server           990 k
 syslinux-extlinux                               x86_64           4.05-13.el7                               beaker-Server           363 k
 unbound-libs                                    x86_64           1.6.3-3.el7                               beaker-Server           391 k
Updating for dependencies:
 libvirt-daemon                                  x86_64           3.7.0-2.el7                               CI-RHEL7.5-1            831 k
 libvirt-daemon-config-network                   x86_64           3.7.0-2.el7                               CI-RHEL7.5-1            157 k
 libvirt-daemon-driver-interface                 x86_64           3.7.0-2.el7                               CI-RHEL7.5-1            202 k
 libvirt-daemon-driver-network                   x86_64           3.7.0-2.el7                               CI-RHEL7.5-1            369 k
 libvirt-daemon-driver-nodedev                   x86_64           3.7.0-2.el7                               CI-RHEL7.5-1            203 k
 libvirt-daemon-driver-nwfilter                  x86_64           3.7.0-2.el7                               CI-RHEL7.5-1            225 k
 libvirt-daemon-driver-qemu                      x86_64           3.7.0-2.el7                               CI-RHEL7.5-1            683 k
 libvirt-daemon-driver-secret                    x86_64           3.7.0-2.el7                               CI-RHEL7.5-1            192 k
 libvirt-daemon-driver-storage                   x86_64           3.7.0-2.el7                               CI-RHEL7.5-1            155 k
 libvirt-daemon-driver-storage-core              x86_64           3.7.0-2.el7                               CI-RHEL7.5-1            383 k
 libvirt-daemon-driver-storage-disk              x86_64           3.7.0-2.el7                               CI-RHEL7.5-1            164 k
 libvirt-daemon-driver-storage-gluster           x86_64           3.7.0-2.el7                               CI-RHEL7.5-1            165 k
 libvirt-daemon-driver-storage-iscsi             x86_64           3.7.0-2.el7                               CI-RHEL7.5-1            161 k
 libvirt-daemon-driver-storage-logical           x86_64           3.7.0-2.el7                               CI-RHEL7.5-1            165 k
 libvirt-daemon-driver-storage-mpath             x86_64           3.7.0-2.el7                               CI-RHEL7.5-1            160 k
 libvirt-daemon-driver-storage-rbd               x86_64           3.7.0-2.el7                               CI-RHEL7.5-1            167 k
 libvirt-daemon-driver-storage-scsi              x86_64           3.7.0-2.el7                               CI-RHEL7.5-1            161 k
 libvirt-daemon-kvm                              x86_64           3.7.0-2.el7                               CI-RHEL7.5-1            155 k
 libvirt-libs                                    x86_64           3.7.0-2.el7                               CI-RHEL7.5-1            4.1 M

3.From above ,kernel-rt has removed from virt-v2v install progress.

HI,rjones, could you help me to check the result,I am not sure if some new unexpected dependence package. Thanks
Comment 14 Richard W.M. Jones 2017-09-21 08:51:43 EDT
Looks OK to me.  The important thing is that kernel-rt is not listed.
Comment 15 kuwei@redhat.com 2017-09-21 21:16:08 EDT
From comment13 and comment14 move the bug to VERIFIED
Comment 18 errata-xmlrpc 2018-04-10 05:15:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0677

Note You need to log in before you can comment on or make changes to this bug.