Bug 1471829 - wrong kernel-rt dependency
wrong kernel-rt dependency
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs (Show other bugs)
7.4
x86_64 Unspecified
high Severity high
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
V2V
: Regression, ZStream
Depends On: 1471651
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-17 10:06 EDT by Oneata Mircea Teodor
Modified: 2018-06-13 03:18 EDT (History)
14 users (show)

See Also:
Fixed In Version: libguestfs-1.36.3-6.el7_4.2
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1471651
Environment:
Last Closed: 2017-08-01 07:30:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oneata Mircea Teodor 2017-07-17 10:06:55 EDT
This bug has been copied from bug #1471651 and has been proposed to be backported to 7.4 z-stream (EUS).
Comment 5 mxie@redhat.com 2017-07-18 02:40:56 EDT
Verify the bug with below builds
virt-v2v-1.36.3-6.el7_4.2.x86_64
libguestfs-1.36.3-6.el7_4.2.x86_64

Steps:
1.Make sure there is no kernel-rt installed on test server 
# rpm -q kernel-rt
package kernel-rt is not installed

2.Prepare the related repo to install virt-v2v
# yum install virt-v2v
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
This system is not registered with an entitlement server. You can use subscription-manager to register.
Resolving Dependencies
--> Running transaction check
---> Package virt-v2v.x86_64 1:1.36.3-6.el7_4.2 will be installed
--> Processing Dependency: libguestfs-tools-c = 1:1.36.3-6.el7_4.2 for package: 1:virt-v2v-1.36.3-6.el7_4.2.x86_64
--> Processing Dependency: libguestfs = 1:1.36.3-6.el7_4.2 for package: 1:virt-v2v-1.36.3-6.el7_4.2.x86_64
--> Processing Dependency: libguestfs.so.0()(64bit) for package: 1:virt-v2v-1.36.3-6.el7_4.2.x86_64
--> Running transaction check
---> Package libguestfs.x86_64 1:1.36.3-6.el7_4.2 will be installed
---> Package libguestfs-tools-c.x86_64 1:1.36.3-6.el7_4.2 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

============================================================================================================
 Package                      Arch             Version                         Repository              Size
============================================================================================================
Installing:
 virt-v2v                     x86_64           1:1.36.3-6.el7_4.2              CI-RHEL7.4-1            12 M
Installing for dependencies:
 libguestfs                   x86_64           1:1.36.3-6.el7_4.2              CI-RHEL7.4-1           1.9 M
 libguestfs-tools-c           x86_64           1:1.36.3-6.el7_4.2              CI-RHEL7.4-1           3.1 M

Transaction Summary
============================================================================================================
Install  1 Package (+2 Dependent packages)

Total download size: 17 M
Installed size: 35 M
Is this ok [y/d/N]: 

3.Check the deplist for libguestfs and there is no kernel-rt package in list
# yum deplist libguestfs

Result:
Libguestfs will not depend on kernel-rt any more, so move the bug from ON_QA to VERIFIED
Comment 6 errata-xmlrpc 2017-08-01 07:30:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2332

Note You need to log in before you can comment on or make changes to this bug.