Bug 1472252 - Satellite throws exception on creating a new/cloned role with taxonomies
Satellite throws exception on creating a new/cloned role with taxonomies
Status: CLOSED DUPLICATE of bug 1444216
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Users & Roles (Show other bugs)
6.3.0
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-18 06:08 EDT by Jitendra Yejare
Modified: 2017-07-18 07:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-18 07:13:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot Attached (76.52 KB, image/png)
2017-07-18 06:08 EDT, Jitendra Yejare
no flags Details

  None (edit)
Description Jitendra Yejare 2017-07-18 06:08:49 EDT
Created attachment 1300371 [details]
Screenshot Attached

Description of problem:
Creating a new role (or cloning a role to new) with taxonomies assigned to role throws role 'is Invalid' error on satellte6 UI, it doesnt creates the role also deslects the taxonomies which I selected while creating a role.

foreman production logs -> https://pastebin.com/xYpR357N


Version-Release number of selected component (if applicable):
Satellite 6.3 Snap 5

How reproducible:
Always

Steps to Reproduce:
1. Attempt to create a new role (or clone manager role)
2. Select Locations and organizations to it
3. Submit the role

Actual results:
1. UI throws an 'is invalid' error message
2. Role is not created
3. Taxonomies of role are deselected which are assigned while creating host

Expected results:
Role with taxonomies should be created and and no UI exceptions should be displayed.

Additional info:
If I create/clone role without assigning taxonomies then it works
Comment 2 Marek Hulan 2017-07-18 07:13:31 EDT
I believe this has been already reported and fixed. The fix has been released in 1.15.2, therefore it's not in any snap atm. Now with the new BZ workflow, I'll update the status of original issue from ON_QA to POST with correct fixed_in_version. Thanks for searching duplicate issue within the component before opening new ones.

*** This bug has been marked as a duplicate of bug 1444216 ***
Comment 3 Marek Hulan 2017-07-18 07:15:46 EDT
A bit more info, the bug that this one duplicated is ON_QA correctly, last snap already contains the fix and is ready to be verified by QE.

Note You need to log in before you can comment on or make changes to this bug.