Bug 1472338 - [v2v] Drivers ISO images are not listed in the v2v dialog as expected.
[v2v] Drivers ISO images are not listed in the v2v dialog as expected.
Status: CLOSED DUPLICATE of bug 1471823
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.8.0
Unspecified Unspecified
high Severity high
: GA
: 5.8.2
Assigned To: Martin Betak
Ilanit Stein
rhev:v2v
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-18 09:31 EDT by Ilanit Stein
Modified: 2017-08-16 06:20 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-07 03:39:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: RHEVM


Attachments (Terms of Use)

  None (edit)
Description Ilanit Stein 2017-07-18 09:31:57 EDT
Description of problem:
On CFME v2v dialog, not all ISO images in the active ISO datastore, added to CFME, under Compute->PXE->ISO are listed.

In fact, it seems only rhev-setup-tools drivers are displayed, if such exist in the ISO datastore. 

Version-Release number of selected component (if applicable):
CFME-5.8.1 + fixes for the install driver field/RHV-4.1.3

Additional info:
On RHV side, v2v dialog, Attach Driver field offer all avalible ISO images in the ISO datastore.
Comment 1 Tomas Jelinek 2017-07-18 11:09:43 EDT
@Moran: there are couple of bugs around iso listing and in order to fix them we need a decision.

The problem:
- currently in manageiq v2v we don't show all the ISOs, only the ones which are containing the virtio drivers (filtered by the iso name and it is broken - 1471823)
- in webadmin we show all the ISOs on the domain and do not try to filter them

So, now we have 2 options:
- fix the regex to properly filter only the ISOs which contain drivers
- remove the filtering completely and show all the ISOs from ISO domain

Both options are trivial to implement but Im not really sure which one is preferable.
Thank you
Comment 3 Ilanit Stein 2017-07-19 03:20:18 EDT
ATM, virtio-win drivers ISO, for example, is not displayed in the v2v dialog\ install Drivers.
Comment 4 Ilanit Stein 2017-07-19 04:17:12 EDT
As mentioned above, on RHV side, v2v dialog, "Attach driver" field offer all available ISO images in the ISO datastore.

Here's a comment from ahadas, 
regarding these ISOs, offered in the v2v dialog, on RHV: 

"There is some heuristic for selecting the most recent relevant iso as default, but the user can select any iso from the iso domain"
Comment 5 Moran Goldboim 2017-07-19 10:16:50 EDT
(In reply to Tomas Jelinek from comment #1)
> @Moran: there are couple of bugs around iso listing and in order to fix them
> we need a decision.
> 
> The problem:
> - currently in manageiq v2v we don't show all the ISOs, only the ones which
> are containing the virtio drivers (filtered by the iso name and it is broken
> - 1471823)
> - in webadmin we show all the ISOs on the domain and do not try to filter
> them
> 
> So, now we have 2 options:
> - fix the regex to properly filter only the ISOs which contain drivers

that would be the preferred option, thanks.

> - remove the filtering completely and show all the ISOs from ISO domain
> 
> Both options are trivial to implement but Im not really sure which one is
> preferable.
> Thank you
Comment 6 Tomas Jelinek 2017-08-07 03:39:35 EDT
this is fixed by the same patches as 1471823 - closing this bug as duplicate to simplify the tracking.

*** This bug has been marked as a duplicate of bug 1471823 ***

Note You need to log in before you can comment on or make changes to this bug.