Bug 1472366 - [RFE] Classic Ironic drivers deprecation
[RFE] Classic Ironic drivers deprecation
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic (Show other bugs)
13.0 (Queens)
Unspecified Unspecified
high Severity high
: Upstream M3
: 13.0 (Queens)
Assigned To: Dmitry Tantsur
mlammon
http://specs.openstack.org/openstack/...
: FutureFeature, Triaged
Depends On: 1373472
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-18 10:54 EDT by Dmitry Tantsur
Modified: 2018-06-27 09:33 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-ironic-10.1.2-0.20180326121311.ef08927.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-06-27 09:32:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1690185 None None None 2017-07-18 10:53 EDT
OpenStack gerrit 534373 None master: MERGED ironic: Automatically migrate nodes to hardware types (I732b44f2ab1ef73f56b352415ffd9cdd8a0e232b) 2018-02-28 08:31 EST
OpenStack gerrit 536928 None master: MERGED ironic: Deprecate classic drivers (I32998c5508e01882714a76751482a916d066f938) 2018-02-28 08:31 EST
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 09:33 EDT

  None (edit)
Description Dmitry Tantsur 2017-07-18 10:54:00 EDT
Upstream has decided to deprecate the classic drivers (e.g. pxe_ipmitool) in favour of the new-style dynamic ones (e.g. ipmi). The deprecation is planned for Queens, and the removal is planned for Rocky.

We need to make sure we provide and support all necessary new-style drivers. We may also provide an upgrade procedure, moving e.g. from pxe_ilo to ilo, etc.
Comment 2 Ramon Acedo 2017-11-02 10:12:19 EDT
Dmitry, is this a TestOnly type of RFE? It looks like this will be replacing the classic drivers by the dynamic ones for QA and update the documentation but there isn't any new code.
Comment 3 Dmitry Tantsur 2017-11-02 13:04:34 EDT
Well, there is some code to write for the actual deprecation warnings, some upstream and downstream docs to update, CI work, etc.
Comment 4 Dmitry Tantsur 2017-12-07 05:23:41 EST
Unfortunately, due to overwhelming amount of documentation to update prior to deprecation, I have to move it to M3.
Comment 8 Dmitry Tantsur 2018-02-02 06:53:09 EST
Moving to POST. Even though https://review.openstack.org/#/c/534842/ is still pending, the core of the feature is there.
Comment 10 Dmitry Tantsur 2018-03-29 09:03:23 EDT
Testing PASSED on RHEL 7.5, puddle 2018-03-29.1, using "ipmi" and "idrac" hardware types. Notes:

Testing - driver availability
-----------------------------

$ openstack baremetal driver list --type dynamic -c 'Supported driver(s)'
+---------------------+
| Supported driver(s) |
+---------------------+
| idrac               |
| ilo                 |
| ipmi                |
| redfish             |
+---------------------+

Testing - enrolling
-------------------

$ cat instackenv.json
{
  "nodes": [
    {
      "name": "host08",
      "pm_password": <hidden>,
      "pm_type": "ipmi",
      "pm_user": "root",
      "pm_addr": "host08-tripleo-drac.mgmt.lab.eng.rdu2.redhat.com"
    },
    {
      "name": "host09",
      "pm_password": <hidden>,
      "pm_type": "idrac",
      "pm_user": "root",
      "pm_addr": "host09-tripleo-drac.mgmt.lab.eng.rdu2.redhat.com"
    }
  ]
}
$ openstack overcloud node import --provide instackenv.json
$ openstack baremetal node list --fields name driver power_interface provision_state power_state
+--------+--------+-----------------+--------------------+-------------+
| Name   | Driver | Power Interface | Provisioning State | Power State |
+--------+--------+-----------------+--------------------+-------------+
| host08 | ipmi   | ipmitool        | available          | power off   |
| host09 | idrac  | idrac           | available          | power off   |
+--------+--------+-----------------+--------------------+-------------+

Testing - upgrade
-----------------

$ openstack baremetal node set host08 --driver pxe_ipmitool
$ openstack baremetal node set host09 --driver pxe_drac
# Simulate upgrade by re-running installation
$ openstack undercloud install
$ openstack baremetal node list --fields name driver power_interface provision_state power_state
+--------+--------+-----------------+--------------------+-------------+
| Name   | Driver | Power Interface | Provisioning State | Power State |
+--------+--------+-----------------+--------------------+-------------+
| host08 | ipmi   | ipmitool        | available          | power off   |
| host09 | idrac  | idrac           | available          | power off   |
+--------+--------+-----------------+--------------------+-------------+
Comment 12 errata-xmlrpc 2018-06-27 09:32:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086

Note You need to log in before you can comment on or make changes to this bug.