Bug 1373472 - [RFE] Driver composition reform
Summary: [RFE] Driver composition reform
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M2
: 12.0 (Pike)
Assignee: Dmitry Tantsur
QA Contact: Dan Yasny
URL:
Whiteboard:
: 1416297 (view as bug list)
Depends On:
Blocks: 1389435 1442136 1411924 1417391 1472366 1477002
TreeView+ depends on / blocked
 
Reported: 2016-09-06 11:32 UTC by Dmitry Tantsur
Modified: 2018-02-05 19:02 UTC (History)
13 users (show)

Fixed In Version: openstack-ironic-8.0.1-0.20170511110442.623eaa0.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-13 20:46:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1524745 None None None 2017-03-29 09:49:37 UTC
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Dmitry Tantsur 2016-09-06 11:32:16 UTC
This is a tracker RFE for the driver composition reform: http://specs.openstack.org/openstack/ironic-specs/specs/approved/driver-composition-reform.html.

The main benefits for us are:
1. Ability to use Ironic "inspect" interface without loosing ironic-inspector features for certain drivers
2. Ability to switch between in-band and out-of-band inspection via API

Comment 2 Dmitry Tantsur 2017-01-06 16:47:06 UTC
Good progress here. It's hard to list all the patches landed and up for landing, just trust me :)

Comment 8 Dmitry Tantsur 2017-01-25 17:47:20 UTC
Blueprint for Director changes: https://blueprints.launchpad.net/tripleo/+spec/ironic-driver-composition

Comment 10 Yoshiki Ohmura 2017-04-05 06:57:20 UTC
*** Bug 1416297 has been marked as a duplicate of this bug. ***

Comment 11 Dmitry Tantsur 2017-04-11 15:04:30 UTC
TripleO integration patch is https://review.openstack.org/#/c/453572/. We'll also need upstream documentation. Afterwards, we can proceed with testing this feature.

Comment 12 Dmitry Tantsur 2017-04-13 16:38:15 UTC
Missed Pike-1 by a tiny margin, still well on track.

Comment 13 Dmitry Tantsur 2017-05-22 17:38:28 UTC
With only upstream documentation left on review, I think we can move this to MODIFIED. Documentation review is https://review.openstack.org/#/c/464656/.

Comment 18 errata-xmlrpc 2017-12-13 20:46:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.