Bug 147251 - trying to compile qemu segfaults gcc 3.4.2-6.fc3
Summary: trying to compile qemu segfaults gcc 3.4.2-6.fc3
Status: CLOSED DUPLICATE of bug 138627
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
(Show other bugs)
Version: 3
Hardware: x86_64 Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL: http://savannah.nongnu.org/projects/qemu
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-05 03:55 UTC by Matthew Daniel
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-06 22:49:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preprocessed source (236.57 KB, application/octet-stream)
2005-02-05 03:56 UTC, Matthew Daniel
no flags Details

Description Matthew Daniel 2005-02-05 03:55:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.5)
Gecko/20041110 Firefox/1.0

Description of problem:
gcc -Wall -O2 -g -fno-strict-aliasing -falign-functions=0
-fno-reorder-blocks -fno-optimize-sibling-calls -I.
-I/usr/src/cvs/qemu/target-i386 -I/usr/src/cvs/qemu
-I/usr/src/cvs/qemu/linux-user -I/usr/src/cvs/qemu/linux-user/i386
-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
-I/usr/src/cvs/qemu/slirp -c -o op.o /usr/src/cvs/qemu/target-i386/op.c
In file included from /usr/src/cvs/qemu/target-i386/op.c:22:
/usr/src/cvs/qemu/target-i386/exec.h:380: warning: conflicting types
for built-in function 'lrintl'
/usr/src/cvs/qemu/target-i386/exec.h: In function `helper_fldt':
/usr/src/cvs/qemu/target-i386/exec.h:521: warning: cast to pointer
from integer of different size
/usr/src/cvs/qemu/target-i386/exec.h: In function `helper_fstt':
/usr/src/cvs/qemu/target-i386/exec.h:526: warning: cast to pointer
from integer of different size
In file included from /usr/src/cvs/qemu/target-i386/op.c:724:
/usr/src/cvs/qemu/target-i386/ops_template.h: In function `op_jb_subb':
/usr/src/cvs/qemu/target-i386/ops_template.h:278: warning: implicit
declaration of function `GOTO_LABEL_PARAM'
/usr/src/cvs/qemu/target-i386/op.c: In function `op_goto_tb0':
/usr/src/cvs/qemu/target-i386/op.c:1277: warning: cast to pointer from
integer of different size
/usr/src/cvs/qemu/target-i386/op.c: In function `op_goto_tb1':
/usr/src/cvs/qemu/target-i386/op.c:1282: warning: cast to pointer from
integer of different size
/usr/src/cvs/qemu/target-i386/op.c: In function `op_divw_AX_T0':
/usr/src/cvs/qemu/target-i386/op.c:374: internal compiler error:
Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /home/mdaniel/.tmp/ccDYy0Vv.out file,
please attach this to your bugreport.


Version-Release number of selected component (if applicable):
gcc-3.4.2-6.fc3

How reproducible:
Didn't try

Steps to Reproduce:
I wanted to get this captured before I try to recompile it.
    

Additional info:

Comment 1 Matthew Daniel 2005-02-05 03:56:56 UTC
Created attachment 110688 [details]
Preprocessed source

Comment 2 Matthew Daniel 2005-02-05 04:02:09 UTC
This is definitely reproducable.
1. cvs co qemu
2. cd qemu; ./configure --prefix=/usr
3. make
4. kaboom

Comment 3 Jakub Jelinek 2005-02-06 22:49:47 UTC

*** This bug has been marked as a duplicate of 138627 ***

Comment 4 Matthew Daniel 2005-02-06 23:16:00 UTC
Sorry for the dupe; i mistakenly only searched the summary field for "qemu" and
not both "summary" and "comments". I won't make that mistake again.



Note You need to log in before you can comment on or make changes to this bug.