Bug 138627 - internal compiler error - segmentation fault
Summary: internal compiler error - segmentation fault
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc   
(Show other bugs)
Version: 3
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
: 147251 151034 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-10 12:10 UTC by Bob Deblier
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-10 22:54:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preprocessed source which caused internal compiler error (162.50 KB, text/plain)
2004-11-10 12:11 UTC, Bob Deblier
no flags Details

Description Bob Deblier 2004-11-10 12:10:05 UTC
Description of problem:
Trying to compile CVS checkout of QEMU on clean install of FC3 x86_64.


Version-Release number of selected component (if applicable):
gcc-3.4.2-6.fc3

How reproducible:
Every time

Steps to Reproduce:
1. Checkout QEMU from http://savannah.nongnu.org/cvs/?group=qemu
2. ./configure
3. make
  
Actual results:
/home/bob/emulators/cvs/qemu/target-i386/op.c: In function
`op_divw_AX_T0':
/home/bob/emulators/cvs/qemu/target-i386/op.c:301: internal compiler
error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/cczk1Bzb.out file, please attach
this to your bugreport.
make[1]: *** [op.o] Error 1


Expected results:
compiled fine on FC2 x86_64 with gcc-3.3.3 (with a patch of dyngen.c)


Additional info:

Comment 1 Bob Deblier 2004-11-10 12:11:24 UTC
Created attachment 106406 [details]
Preprocessed source which caused internal compiler error

Comment 2 Jakub Jelinek 2004-11-10 22:54:01 UTC
This is already tracked upstream:
http://gcc.gnu.org/PR17825

Comment 3 Jakub Jelinek 2004-11-22 10:49:53 UTC
Should be fixed in gcc-3.4.3-4 in rawhide.

Comment 4 Jakub Jelinek 2005-02-06 22:49:54 UTC
*** Bug 147251 has been marked as a duplicate of this bug. ***

Comment 5 Dag Wieers 2005-03-10 23:10:33 UTC
I guess an update will not be released for FC3. Is there an easy
work-around to get Qemu build on the vanilla FC3 compiler ?

Comment 6 Bob Deblier 2005-03-11 05:51:07 UTC
I've been using gcc-3.4.3 from the development tree, which compiles
qemu without problems.

Comment 7 Jakub Jelinek 2005-03-14 09:03:16 UTC
*** Bug 151034 has been marked as a duplicate of this bug. ***

Comment 8 Paul Jakma 2005-03-14 09:21:41 UTC
I know this has been closed, but there is no gcc-3.4 in Rawhide/FC-devel
anymore. There is only compat-gcc32 and gcc-4.0. Is there any way to get a fixed
gcc 3.4 for FC3?



Note You need to log in before you can comment on or make changes to this bug.