Bug 1472587 - Make performance & scale tunings as default
Make performance & scale tunings as default
Status: CLOSED DUPLICATE of bug 1312098
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Performance (Show other bugs)
6.2.10
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-19 01:06 EDT by sbadhwar
Modified: 2017-08-08 07:00 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-08 07:00:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sbadhwar 2017-07-19 01:06:31 EDT
Description of problem:
The current defaults in Satellite 6.2 are very conservative for any practical deployment.

We would have to make some of the tunings as mentioned in the Satellite Performance and Scale Brief, default in the upcoming releases for Satellite.

Some of the tunings that can be made to go default include:

1). /etc/httpd/conf.d/05-foreman-ssl.d/katello.conf
KeepAlive On
MaxKeepAliveRequests 0
KeepAliveTimeout 5

2). cat /etc/systemd/system/httpd.service.d/limits.conf
LimitNOFILE=640000

3). /etc/systemd/system/qpidd.service.d/limits.conf
LimitNOFILE=640000

4). /etc/systemd/system/qdrouterd.service.d/limits.conf
LimitNOFILE=640000

5). /var/lib/pgsql/data/postgresql.conf
shared_buffers = 256MB
work_mem=4MB

6). /etc/systemd/system/smart_proxy_dynflow_core.service.d/limits.conf
LimitNOFILE=640000

7) Application level passenger tunings.

/etc/httpd/conf.d/05-foreman-ssl.conf

PassengerAppRoot /usr/share/foreman
PassengerRuby /usr/bin/ruby193-ruby
PassengerMinInstances 6
PassengerStartTimeout 500
PassengerMaxPreloaderIdleTime 0
PassengerMaxRequests 10000
PassengerPreStart https://example.com

  /etc/httpd/conf.d/25-puppet.conf
PassengerMinInstances 6
PassengerStartTimeout 500
PassengerMaxPreloaderIdleTime 0
PassengerMaxRequests 10000
PassengerPreStart https://example.com:8140

Note 1: The PassengerMinInstances has the max limit of equivalent to PassengerMaxPoolSize

Note 2: We are currently evaluating the performance tunings for Satellite 6.3, but except the passenger tunings mentioned here, all other tunings can be made to go default in 6.3 release also.
Comment 2 Brad Buckingham 2017-08-04 10:06:14 EDT
Hello Saurabh,

Thank you for the bugzilla report.  This looks like it may be considered a duplicate of bug 1312098.  That bug is tracking the need to improve the default tuning of Satellite 6.  Any objections to closing this one so that we can track the issue on a single place?
Comment 3 sbadhwar 2017-08-08 00:24:46 EDT
(In reply to Brad Buckingham from comment #2)
> Hello Saurabh,
> 
> Thank you for the bugzilla report.  This looks like it may be considered a
> duplicate of bug 1312098.  That bug is tracking the need to improve the
> default tuning of Satellite 6.  Any objections to closing this one so that
> we can track the issue on a single place?

Hey Brad,

Just took a look at the BZ you mentioned and I think, we can close this bug with the tunings mentioned in the description of this bug copied over to bug 1312098.
Comment 4 Brad Buckingham 2017-08-08 07:00:02 EDT

*** This bug has been marked as a duplicate of bug 1312098 ***

Note You need to log in before you can comment on or make changes to this bug.