Bug 1472627 - Update gcc-libraries for DTS-7.0
Update gcc-libraries for DTS-7.0
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gcc-libraries (Show other bugs)
6.10
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Marek Polacek
Michael Petlan
: Improvement, ZStream
Depends On: 1465568
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-19 02:46 EDT by Oneata Mircea Teodor
Modified: 2017-10-03 10:27 EDT (History)
5 users (show)

See Also:
Fixed In Version: gcc-libraries-7.1.1-2.3.1.el6_9
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1465568
Environment:
Last Closed: 2017-10-03 10:27:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oneata Mircea Teodor 2017-07-19 02:46:52 EDT
This bug has been copied from bug #1465568 and has been proposed to be backported to 6.9 z-stream (EUS).
Comment 3 Michael Petlan 2017-08-08 08:34:53 EDT
Rebuilding gcc-libraries-7.1.1-2.3.1.el6_9.src.rpm and reviewing the related parts of the testsuite, I saw the following FAILs. The rest was OK. Can we waive that and proceed?

======== ppc64 ========
FAIL: gfortran.dg/ieee/large_2.f90   -O0  execution test
FAIL: gfortran.dg/ieee/large_2.f90   -O1  execution test
FAIL: gfortran.dg/ieee/large_2.f90   -O2  execution test
FAIL: gfortran.dg/ieee/large_2.f90   -O3 -fomit-frame-pointer -funroll-loops -fpeel-loops -ftracer -finline-functions  execution test
FAIL: gfortran.dg/ieee/large_2.f90   -O3 -g  execution test
FAIL: gfortran.dg/ieee/large_2.f90   -Os  execution test
FAIL: gfortran.dg/vect/pr48329.f90   -O   scan-tree-dump-times vect "vectorized 1 loops" 1
FAIL: gfortran.dg/vect/pr62283-2.f   -O   scan-tree-dump slp2 "basic block vectorized"
FAIL: gfortran.dg/ieee/large_2.f90   -O0  execution test
FAIL: gfortran.dg/ieee/large_2.f90   -O1  execution test
FAIL: gfortran.dg/ieee/large_2.f90   -O2  execution test
FAIL: gfortran.dg/ieee/large_2.f90   -O3 -fomit-frame-pointer -funroll-loops -fpeel-loops -ftracer -finline-functions  execution test
FAIL: gfortran.dg/ieee/large_2.f90   -O3 -g  execution test
FAIL: gfortran.dg/ieee/large_2.f90   -Os  execution test
FAIL: gfortran.dg/vect/pr48329.f90   -O   scan-tree-dump-times vect "vectorized 1 loops" 1
FAIL: gfortran.dg/vect/pr62283-2.f   -O   scan-tree-dump slp2 "basic block vectorized"

======== i686 ========
FAIL: gfortran.dg/vect/fast-math-mgrid-resid.f   -O   scan-tree-dump pcom "vectp_u.*__lsm.* = PHI <.*vectp_u.*__lsm"
FAIL: gfortran.dg/vect/fast-math-mgrid-resid.f   -O   scan-tree-dump pcom "vectp_u.*__lsm.* = PHI <.*vectp_u.*__lsm"
Comment 4 Marek Polacek 2017-08-08 10:16:09 EDT
Yes, you can waive these.  (I've checked whether devtoolset-7-gcc for el6 has these fails too, and indeed it has.)
Comment 5 Michael Petlan 2017-08-08 10:52:12 EDT
OK, thanks. So, since the rest of results look nice, moving to VERIFIED.
Comment 7 errata-xmlrpc 2017-10-03 10:27:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2848

Note You need to log in before you can comment on or make changes to this bug.