Bug 147272 - RFE: Eject button in anaconda dialog when CDs are being switched (particularly useful for PPC)
RFE: Eject button in anaconda dialog when CDs are being switched (particularl...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
: 146411 (view as bug list)
Depends On:
Blocks: fedora-ppc
  Show dependency treegraph
 
Reported: 2005-02-05 19:08 EST by Mike MacCana
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-14 01:55:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike MacCana 2005-02-05 19:08:29 EST
Description of problem:
New PCs don't have eject buttons on their CD ROM drives. Mac Minis for
one thing, but its likely the trend will be copied. It'd be nice if
the installer had an eject CD dialog. 

Otherwise users have to Ctrl-Alt-F2 and run eject themselves, or do a
network install.

Justification: This'd help get Fedora PPC up to the same state as its
other platform counterparts, but would be nice for other users of
other architectures too.
Comment 1 Jeremy Katz 2005-02-07 10:27:22 EST
The CD should already be getting ejected when we go to switch CDs... 
is that not happening?  
Comment 2 Paul Nasrat 2005-02-07 10:42:08 EST
*** Bug 146411 has been marked as a duplicate of this bug. ***
Comment 3 Paul Nasrat 2005-02-07 11:47:01 EST
It's switching from boot.iso to cd1, as opposed to cd1 to cd2 I
believe.  I'll do an install on the iMac after lunch (pre rpm 4.4)
Comment 4 David Woodhouse 2005-02-17 10:42:22 EST
We should also make CD1 on PPC bootable. We should do that once we've
sorted out the details of how you make a single bootable CD which
handles all four of {Mac,CHRP} {32-bit,64-bit}.
Comment 5 Paul Nasrat 2005-03-14 01:54:11 EST
We should now always be ejecting in this case ore cd installs.
Comment 6 Paul Nasrat 2005-03-16 09:58:28 EST
For those having issues with eject who can't do a network install of Fedora Core
4 Test 1.

Here is a 32 bit image that will boot your mac off a usb key

It's a hd image with mac partition table, a hfs apple_bootstrap and an
ext2 partition with the kernel/initrd.  Created on an x86 linux box with
parted, hfsutils, and offset loopback mount for the ext2 parts.

http://people.redhat.com/pnasrat/ppcboot.img

0074caa1772d12ee969decb9c222614b47cb7d67  ppcboot.img

dd if=ppcboot.img of=/dev/sda bs=1k

where sda is your usb storage device 

pop the usb key into your mac.  Power up holding the option key (alt)
down and you should get the graphical chooser.  Choose the disk with the
USB logo below it and the small tux log.

Click on the -> arrow and it should take you there.

Note You need to log in before you can comment on or make changes to this bug.