Bug 147283 - FC3 Sound not working - Intel 82801 on board sound controller
FC3 Sound not working - Intel 82801 on board sound controller
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
: 140851 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-06 04:03 EST by Gerard Fernandes
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-02 02:47:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My "modprobe.conf" (423 bytes, text/plain)
2005-02-08 05:05 EST, Gerard Fernandes
no flags Details

  None (edit)
Description Gerard Fernandes 2005-02-06 04:03:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Installed FC3 on an Acer 4000 series laptop with on-board Intel 82801
sound. Sound not working.
Was working with FC2 on the same laptop.

Version-Release number of selected component (if applicable):
alsa-lib-1.0.6-7.FC3,kernel-2.6.10-1.760_FC3

How reproducible:
Always

Steps to Reproduce:
1. Install FC3
2. On the first-time login wizard, Sound card seems to be detected
correctly.
3. Click on Play Test Sound - no sound.
4. Update the system (all updates applied as of 5-Feb-2005).
5. Check sound from "Applications/System Settings/Soundcard Detection.
6. Again Sound-card seems to be detected correctly (shows the
string"Intel Corp 82801DB/DBL/DBM(ICH4/ICH4-L/ICH4-M) AC'97 Audio
Controller"
7. Click on the "Play Test Sound" button. No sound.
    

Actual Results:  No sound.

Expected Results:  Should be able to hear the test sound.

Additional info:

Was working perfectly in FC2 on the same laptop. However, even in FC2,
Audio-CDs could not be heard in FC2. Audio CDs worked in Windows XP
though.
Comment 1 Gerard Fernandes 2005-02-06 11:24:36 EST
WORKAROUND:

http://www.redhat.com/archives/fedora-test-list/2004-November/msg00734.html

This link restored sound on my Acer laptop.
Comment 2 Gerard Fernandes 2005-02-06 11:40:10 EST
However there is still no sound from audio CDs.
Comment 3 Martin Stransky 2005-02-08 04:31:39 EST
Do you have any software modem? Could you attach your
/etc/modprobe.conf and output from lsmod?
Thanks
Comment 4 Gerard Fernandes 2005-02-08 05:05:04 EST
Created attachment 110783 [details]
My "modprobe.conf"
Comment 5 Gerard Fernandes 2005-02-08 05:06:56 EST
Thanks Martin. Here is the output of "lsmod":
===========================================================
Module                  Size  Used by
i915                   74821  5
parport_pc             26629  0
lp                     12077  0
parport                37001  2 parport_pc,lp
autofs4                23493  0
sunrpc                156325  1
pcmcia                 20805  2
ipt_REJECT              6593  1
ipt_state               1857  1
ip_conntrack           40309  1 ipt_state
iptable_filter          3521  1
ip_tables              16321  3 ipt_REJECT,ipt_state,iptable_filter
vfat                   12609  1
fat                    39905  1 vfat
dm_mod                 55637  0
video                  15813  0
button                  6609  0
battery                 9285  0
ac                      4805  0
md5                     4033  1
ipv6                  231681  8
joydev                  9217  0
ohci1394               34777  0
ieee1394              300313  1 ohci1394
yenta_socket           19137  0
pcmcia_core            50945  2 pcmcia,yenta_socket
uhci_hcd               31449  0
ehci_hcd               35273  0
i2c_i801                8141  0
i2c_core               20801  1 i2c_i801
snd_intel8x0           33249  2
snd_ac97_codec         67489  1 snd_intel8x0
snd_pcm_oss            47989  0
snd_mixer_oss          17089  2 snd_pcm_oss
snd_pcm                93001  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              29125  1 snd_pcm
snd                    52645  8
snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              10017  2 snd
snd_page_alloc          9541  2 snd_intel8x0,snd_pcm
ipw2200                62029  0
ieee80211              19525  1 ipw2200
ieee80211_crypt         6725  1 ieee80211
b44                    23365  0
mii                     4673  1 b44
ext3                  116297  2
jbd                    69977  1 ext3
Comment 6 Gerard Fernandes 2005-02-08 05:14:44 EST
Hello Martin,

Yes, this laptop comes with an onboard software modem. Dont know which
one though I suspect it is a Conexant one. I have no use for the
modem. I always use an external model or (as I am doing right now) an
ADSL connection via the onboard ethernet card. Maybe if its possible
to disable it somehow sound from the CD will work?

Thanks once more for your help.
Comment 7 Gerard Fernandes 2005-02-08 05:23:43 EST
Hello Martin,

Here is what "lspci" has to say about the modem:

00:1f.6 Modem: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97
Modem Controller (rev 03)

I guess that means its an Intel AC'97 Soft-modem?

Thanks.
Comment 8 Martin Stransky 2005-02-08 05:28:51 EST
Yes. I think it can be a problem. Could you please attach files:

/proc/asound/pcm
/proc/asound/cards
/proc/asound/modules
/proc/asound/devices

Thanks.
Comment 9 Gerard Fernandes 2005-02-08 06:18:33 EST
Hello Martin,

Here is the contents of my "/proc/asound/pcm" file:
==============================================
00-00: Intel ICH : Intel 82801DB-ICH4 : playback 1 : capture 1
00-01: Intel ICH - MIC ADC : Intel 82801DB-ICH4 - MIC ADC : capture 1
00-02: Intel ICH - MIC2 ADC : Intel 82801DB-ICH4 - MIC2 ADC : capture 1
00-03: Intel ICH - ADC2 : Intel 82801DB-ICH4 - ADC2 : capture 1
00-04: Intel ICH - IEC958 : Intel 82801DB-ICH4 - IEC958 : playback 1
==============================================

my "/proc/asound/cards" file:
==============================================
0 [I82801DBICH4   ]: ICH4 - Intel 82801DB-ICH4
                     Intel 82801DB-ICH4 with unknown codec at
0xe0100c00, irq 10
==============================================

my "/proc/asound/modules" file:
==============================================
0 snd_intel8x0
==============================================

my "/proc/asound/devices" file
==============================================
 20: [0- 4]: digital audio playback
 27: [0- 3]: digital audio capture
 26: [0- 2]: digital audio capture
 25: [0- 1]: digital audio capture
 16: [0- 0]: digital audio playback
 24: [0- 0]: digital audio capture
 33:       : timer

Thanks.
Comment 10 Martin Stransky 2005-02-08 07:01:39 EST
Could you please attach output from "lspci"?
Comment 11 Gerard Fernandes 2005-02-08 07:28:19 EST
Hi Martin

Here is the output from "lspci":
================================
00:00.0 Host bridge: Intel Corp. 82852/82855 GM/GME/PM/GMV Processor
to I/O Controller (rev 02)
00:00.1 System peripheral: Intel Corp. 82852/82855 GM/GME/PM/GMV
Processor to I/O Controller (rev 02)
00:00.3 System peripheral: Intel Corp. 82852/82855 GM/GME/PM/GMV
Processor to I/O Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corp. 82852/855GM Integrated
Graphics Device (rev 02)
00:02.1 Display controller: Intel Corp. 82852/855GM Integrated
Graphics Device (rev 02)
00:1d.0 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corp. 82801DB/DBM (ICH4/ICH4-M) USB2
EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corp. 82801 Mobile PCI Bridge (rev 83)
00:1f.0 ISA bridge: Intel Corp. 82801DBM (ICH4-M) LPC Interface Bridge
(rev 03)
00:1f.1 IDE interface: Intel Corp. 82801DBM (ICH4-M) IDE Controller
(rev 03)
00:1f.3 SMBus: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus
Controller (rev 03)
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
00:1f.6 Modem: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97
Modem Controller (rev 03)
02:02.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T
(rev 01)
02:04.0 Network controller: Intel Corp. PRO/Wireless 2200BG (rev 05)
02:06.0 CardBus bridge: Texas Instruments: Unknown device 8031
02:06.2 FireWire (IEEE 1394): Texas Instruments: Unknown device 8032
02:06.3 Unknown mass storage controller: Texas Instruments: Unknown
device 8033

================================================================
Thanks.
Comment 12 Gerard Fernandes 2005-02-08 12:20:17 EST
Also, and I dont know if this is relevant information - but it seems
to be related, the sound mute/unmute keyboard short cut no longer
works. It simply reduces volume to zero.

Thanks.
Comment 13 Gerard Fernandes 2005-02-09 12:15:20 EST
FYI.....the sound mute/unmute worked in FC2.

Thanks.
Comment 14 Martin Stransky 2005-02-11 05:06:59 EST
Could you please joint output from "lspci -v"?
(only devices 00:1f.5, 00:1f.6 - souncard/modem)
Thanks
Comment 15 Gerard Fernandes 2005-02-11 06:23:36 EST
Here is the output of "lspci -v" (soundcard/modem only):
========================================================

00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/IC H4-M) AC'97 Audio Controller (rev 03)
        Subsystem: Acer Incorporated [ALI]: Unknown device 0064
        Flags: bus master, medium devsel, latency 0, IRQ 10
        I/O ports at 1c00 [size=256]
        I/O ports at 18c0 [size=64]
        Memory at e0100c00 (32-bit, non-prefetchable) [size=512]
        Memory at e0100800 (32-bit, non-prefetchable) [size=256]
        Capabilities: [50] Power Management version 2

00:1f.6 Modem: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97
Modem Cont roller (rev 03) (prog-if 00 [Generic])
        Subsystem: Acer Incorporated [ALI]: Unknown device 0064
        Flags: medium devsel, IRQ 10
        I/O ports at 2400 [size=256]
        I/O ports at 2000 [size=128]
        Capabilities: [50] Power Management version 2
========================================================

Thanks.
Comment 16 Gerard Fernandes 2005-02-13 13:27:59 EST
Also, and I dont know whether this is a hardware limitation, this
driver allows only one program to use it at any given point in time -
i.e. access to the hardware is sequential.

Therefore, for example, if I have GAIM and XMMS on at the same time,
and XMMS is playing a song, GAIM cannot play audio alerts. Conversely,
in between songs, GAIM gets access and plays all queued audio alerts
and does not allow XMMS to play the next song until all queued alerts
are done!!!

Is this because the hardware is not full-duplex? I do not have this
problem on my desktop which uses SB Live for the sound.

Thanks.
Comment 17 Martin Stransky 2005-03-01 09:36:16 EST
Hm, every looks properly. Could you try new kernel and alsa-lib/utils?
(from devel). There is alsa-1.0.8, in FC3 is only 1.0.6.
Comment 18 Carmit Levi 2005-03-18 07:54:29 EST
hi
i am new linux user and i have this problem too
i am not so good with linux yet but i know somethings about programing

i think the problem is not with the alsa because the same works fine with
previous kernels...

i the change which fuck was like that (i think)
the old kernels come with OSS and the new ones come with ALSA support (as defult)

i think that the alsa functionality depends with the old oss which is not
installed automaticly in the new kernel such as ALSA...



Comment 19 Carmit Levi 2005-03-19 09:59:07 EST
hi again
i downloaded the newest alsa and installed it
after this it still wrong
then i used ossmixer to set volume to 10
i entered the bios and made the sound unavailable
after this i declared on the configuration that there is no sound card
i rebooted and rebake the sound card (BIOS)
the system recognize the sound card again and reconfigured it onload
then i did sound test from gnome system preference
and the test worked 


(In reply to comment #18)
> hi
> i am new linux user and i have this problem too
> i am not so good with linux yet but i know somethings about programing
> 
> i think the problem is not with the alsa because the same works fine with
> previous kernels...
> 
> i the change which fuck was like that (i think)
> the old kernels come with OSS and the new ones come with ALSA support (as defult)
> 
> i think that the alsa functionality depends with the old oss which is not
> installed automaticly in the new kernel such as ALSA...
> 
> 
> 
> 

Comment 20 Gerard Fernandes 2005-03-19 16:21:48 EST
I have the latest kernel I think - kernel-2.6.10-1.770_FC3. However I do not
have the latest alsa package yet - currently on alsa-lib-1.0.6-7.FC3.

I will install and update.
Comment 21 Martin Stransky 2005-04-22 08:01:35 EDT
Or you can try to update udev package - 

https://bugzilla.redhat.com/bugzilla-old/show_bug.cgi?id=154820

Comment 22 Gerard Fernandes 2005-04-23 11:16:29 EDT
I'm just recently updated the system and its now running on:
* kernel: kernel-2.6.11-1.14_FC3
* alsa: alsa-lib-1.0.6-8.FC3

I also seem to have the latest stable FC3 udev package:
udev-039-10.FC3.7

Audio CDs still play - though not audibly, no matter what the volume
;) - and mute only reduces volume to 0: which means that unmute does
nothing at all...

Is there a higher version of udev that I should try?

Thanks for the help... :)
Comment 23 Martin Stransky 2005-05-10 06:24:50 EDT
I meant version from FC4, it may help you. 

The volume control is problem of your sound card, it probably can't
handle it and you have to use a plugin for software volume control.

In FC4, you can use device "cards.pcm.default", it has (for ICH4) a
software volume control plug-in.
Comment 24 Gerard Fernandes 2005-05-10 15:48:45 EDT
I'm pretty sure its a kernel module thing. Unless it worked with the
OSS driver and the ALSA driver doesn't properly support it. This was
working in FC2.
Comment 25 Martin Stransky 2005-05-11 05:03:23 EDT
About audio CDs, if your laptop doesn't have connection between CD-ROM
drive and sound card, you have to use digital playback from Audio CDs.

e.g. run xmms, open preferences and configure 'CD Audio input' plug-in
- select 'Digital audio extraction'.

About audio chanels mixing, you have to use dmix for it or some sound
server (like aRts, it's part of KDE). ICH4 device can always play
sound from only one source.

About ALSA drivers for ICH devices, they are still under development,
so you can try to use some old drivers or wait for a new one.
Comment 26 Gerard Fernandes 2005-05-11 15:33:28 EDT
You're absolutely correct :)

I'm very sorry for barking up the wrong tree. Apparently its neither a
kernel nor an ALSA thing. XMMS plays audio CDs fine after performing
the steps above.

The problem might be with the default Gnome CD Player - which does not
seem to support digital audio extraction at this point in time.

I suppose this means this bug is just a red-herring then.
Comment 27 joe 2005-05-26 11:36:49 EDT
I have had consistent sound problems with FC1 FC2 and FC3 - sometimes it works
and sometimes it does not.

MY SOLUTION: I discovered a quick fix on the internet the other day - mute both
microphone entries SystemSettings->SoundDetection.

There are a lot of people suggesting a lot of things to help people with sound
problems - if a simple mute of the microphone could help half of them - maybe
that could be the default for sound i.e. microphones=muted during install?

But if I was just one of a lucky few - I will be back - because I have had a lot
of problems with sound.

Comment 28 joe 2005-05-26 11:46:02 EDT
(In reply to comment #27)

Oops - should be SoundVideo->VolumeControl.
Comment 29 Gerard Fernandes 2005-06-18 19:31:56 EDT
I'm sorry to add that the same problem for which I logged this bug originally -
sound not working out of the box on an Intel 82801 board still persists in FC4.

I've just installed FC4 and sound is still broken. I still need to apply the
work around:
http://www.redhat.com/archives/fedora-test-list/2004-November/msg00734.html

to get it working.

I wonder why the offending module has not been black-listed out of the box?

Comment 30 Gerard Fernandes 2005-06-19 12:55:19 EDT
By the way, is there a kudozilla somewhere for Fedora? You guys have once again
done a fantastic job. I always wonder how you guys manage it. Its just fantastico! 

Bluecurve just got better, smoother and more sophisticated! If you guys keep up
this pace what will happen to Apple?

Little things here and there detract from the overall brilliance of FC4. But
that aside, its a great upgrade - and a very beautiful and stable one at that.
Comment 31 Martin Stransky 2005-06-27 10:54:07 EDT
*** Bug 140851 has been marked as a duplicate of this bug. ***
Comment 32 Martin Stransky 2005-06-29 08:16:31 EDT
Thanks :)

btw. I can't add intel8x0m driver to black-list, because if I do it,
you can't use a software modem...
Comment 33 Richard Körber 2005-07-11 03:08:15 EDT
I've got some issues with FC4 and a 82801EB/ER (ICH5/ICH5R) audio controller,
together with XMMS.

When I use ALSA as output device for XMMS, the music frequently justs "pauses".
I mean, it just stops playing in the middle of the track. I have to press the
pause button twice in order to resume playing.

Now, when I switch XMMS to OSS, the music keeps on playing fine. Anyhow, during
playback no other software is able to play any sound, and sometimes XMMS also
complains that it was unable to open the audio device.

I cannot remember that I was having such issues with FC3.

Kernel 2.6.12-1.1387_FC4

alsa-lib-1.0.9rf-2.FC4
alsa-utils-1.0.9rf-2.FC4
alsa-lib-devel-1.0.9rf-2.FC4
Comment 34 Martin Stransky 2005-07-11 03:31:39 EDT
(In reply to comment #33)
> I've got some issues with FC4 and a 82801EB/ER (ICH5/ICH5R) audio controller,
> together with XMMS.
> 
> When I use ALSA as output device for XMMS, the music frequently justs "pauses".
> I mean, it just stops playing in the middle of the track. I have to press the
> pause button twice in order to resume playing.
> 
> Now, when I switch XMMS to OSS, the music keeps on playing fine. Anyhow, during
> playback no other software is able to play any sound, and sometimes XMMS also
> complains that it was unable to open the audio device.
> 
> I cannot remember that I was having such issues with FC3.
> 
> Kernel 2.6.12-1.1387_FC4
> 
> alsa-lib-1.0.9rf-2.FC4
> alsa-utils-1.0.9rf-2.FC4
> alsa-lib-devel-1.0.9rf-2.FC4

It's caused by dmix plug-in, which is enabled for cards which don't have any HW
mixer. You can turn it off, if you write these lines to /etc/asound.conf:

pcm.!default { type hw card 0 }
ctl.!default { type hw card 0 }

Comment 35 Richard Körber 2005-07-11 08:23:07 EDT
(In reply to comment #34)
> pcm.!default { type hw card 0 }
> ctl.!default { type hw card 0 }

Thanks... The music keeps on playing now.

Anyhow since the audio controller does not support hardware mixing, I am still
unable to use more than one sound source:

# XMMS is currently playing a song, ALSA output is used.
$ play shutdown1.wav
sox: Can't open output file '/dev/dsp': Device or resource busy
Comment 36 Martin Stransky 2005-07-12 03:53:07 EDT
Yes, in this case you have to use some software mixer like arts...
Comment 37 Martin Stransky 2005-08-02 02:47:44 EDT
Added new HW switch to c-s-c (in rawhide) to bypass dmix.

Note You need to log in before you can comment on or make changes to this bug.