Bug 1472874 - Stale bucket index entries are left over after object deletions due to invalid timespan issues
Summary: Stale bucket index entries are left over after object deletions due to invali...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.3
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: rc
: 3.0
Assignee: Matt Benjamin (redhat)
QA Contact: vidushi
Erin Donnelly
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1473188 1479771 1494421
TreeView+ depends on / blocked
 
Reported: 2017-07-19 15:02 UTC by Benjamin Schmaus
Modified: 2017-12-05 23:36 UTC (History)
12 users (show)

(edit)
.Deleting objects no longer leaves stale bucket index entries 

Previously, when objects were removed from the Ceph Object Gateway, the `radosgw` daemon could fail to remove the entries of the deleted objects due to a time scaling error. This bug has been fixed, and `radosgw` removes the bucket index entries as expected.
Clone Of:
: 1479771 (view as bug list)
(edit)
Last Closed: 2017-12-05 23:36:49 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3387 normal SHIPPED_LIVE Red Hat Ceph Storage 3.0 bug fix and enhancement update 2017-12-06 03:03:45 UTC
Ceph Project Bug Tracker 20513 None None None 2017-07-19 15:02 UTC

Description Benjamin Schmaus 2017-07-19 15:02:12 UTC
Description of problem:

Stale bucket index entries are left over after object deletions due to invalid timespan issues

https://github.com/ceph/ceph/pull/16289/files


Version-Release number of selected component (if applicable):
2.3

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 16 errata-xmlrpc 2017-12-05 23:36:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387


Note You need to log in before you can comment on or make changes to this bug.