Bug 147299 - 2.6.10 series kernels hang on boot
2.6.10 series kernels hang on boot
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Depends On:
  Show dependency treegraph
Reported: 2005-02-06 13:35 EST by Karl Hansen
Modified: 2015-01-04 17:16 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-28 04:16:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Chunk of /var/log/messages cooresponding to 2.6.10-770 boot and hang (14.98 KB, text/plain)
2005-03-07 10:33 EST, mgm
no flags Details

  None (edit)
Description Karl Hansen 2005-02-06 13:35:21 EST
Description of problem:  Updated kernels in the 2.6.10 series hang on
boot at after the only text line and before blank screen before boot
continues under GUI and login.

Version-Release number of selected component (if applicable):

Works with 2.6.9 but will not work with 2.6.10 kernels

How reproducible: has, at best, booted once

Steps to Reproduce:
1.Turn off
3.Turn off when fails to boot
Actual results:

Does not boot

Expected results:
System to boot normally

Additional info:

XP3000 Nforce chipset.  The 2.6.9 724 kernel is the last one that
works.  I think that is the last one in the 9 series.
Comment 1 Sitsofe Wheeler 2005-02-06 14:45:08 EST
Does removing rhgb from the grub boot menu get any further?
Comment 2 Karl Hansen 2005-02-06 15:14:38 EST
After removing rhgb, the system hangs on "Checking for new hardware".
Comment 3 Sitsofe Wheeler 2005-02-07 03:13:53 EST
If you have any non usb keyboard devices plugged in try unplugging and then
booting to see if it gets any further.
Comment 4 Karl Hansen 2005-02-07 19:50:30 EST
I tried removeing keyboard, mouse, and/or usb cables.  No change.
Comment 5 mgm 2005-02-08 15:18:33 EST
I experience this same problem with a Compaq 1800T laptop.  The laptop
hangs at EVERY boot with a 2.6.10- kernel.  No text to indicate what
went wrong, nothing conclusive in dmesg afterwards.

2.6.9-XXX  - Works every time.
2.6.10-XXX - Hangs every time.

Seems like it hangs starting CUPS, but this may only be what it looks
like because that's the last thing printed to the screen successfully.
 Power-cycle is required to reboot.
Comment 6 mgm 2005-02-08 15:22:04 EST
Forgot to mention, my experience sounds similar to Bug 146472 as well,
so these may be related.
Comment 7 Karl Hansen 2005-02-08 22:02:00 EST
When hung at Checking for new hardware Ctrl Alt Del will cause the
system to initiate the termination sequence and the system will
reboot, but still hang.
Comment 8 Marc Mondragon 2005-02-12 17:44:47 EST
I also have not been able to boot a 2.6.10 kernel.  The one I am able to boot
with is of the 2.6.9 vintage.  Mine always hangs right after displaying: 
"Enabling swap space:  [OK]". I've tried to put echo's in the rc.sysinit file to
see exactly where it is dying without any success.  In fact it doesn't even
finish printing the final echo I put in the rc.sysinit before it hangs.  Only
way to reboot is through the reset or power button.  FWIW, I have a MSI K8N Neo
Platinum motherboard w/ AMD64 2800+ CPU.
Comment 9 Marc Mondragon 2005-02-12 18:00:50 EST
After reading the previois comments I decided to try and reboot
without any USB devices attached... Booted right up.  I was able to
then plug-in my usb devices (keyboard, mouse, etc) and continue.  The
following was grabbed from my dmesg after I plugged things back in: 

usb 1-4: new high speed USB device using ehci_hcd and address 2
usb 1-4: device descriptor read/64, error -71
hub 1-4:1.0: USB hub found
hub 1-4:1.0: 4 ports detected
ohci_hcd 0000:00:02.1: wakeup
usb 3-1: new full speed USB device using ohci_hcd and address 2
hub 3-1:1.0: USB hub found
hub 3-1:1.0: 3 ports detected
usb 3-1.1: new full speed USB device using ohci_hcd and address 3
input: USB HID v1.00 Keyboard [NMB Dell USB 7HK Keyboard] on
input,hiddev96: USB HID v1.00 Device [NMB Dell USB 7HK Keyboard] on
usb 3-1.2: new low speed USB device using ohci_hcd and address 4
input: USB HID v1.10 Mouse [Microsoft Microsoft 3-Button Mouse with
IntelliEye(TM)] on usb-0000:00:02.1-1.2
drivers/usb/input/hid-input.c: event field not found
Comment 10 Dave Jones 2005-02-12 18:05:38 EST
can you try the 766 kernel in updates-testing ?  I made some changes
to USB probing that may help.
Comment 11 Marc Mondragon 2005-02-12 18:17:35 EST
That is the version I'm using.  Just installed it this morning.
Comment 12 Karl Hansen 2005-02-12 18:56:00 EST
I just tried the 766 kernel, without anything plugged in the USB
ports.  It hangs for me at checking for new hardware.  I do not know
if it is significant, but when I terminate the program it gives a USB
busy indication.  I am not running a USB mouse of keyboard, so nothing
is plugged in.
Comment 13 Sitsofe Wheeler 2005-02-21 15:20:28 EST
Does booting with the nousb parameter let things get any further (for those who
don't need usb)?
Comment 14 Marc Mondragon 2005-02-21 15:33:26 EST
I download 2.6.10-1.767_FC3 from Dave Jones test area and it fixed the problem I
was having.  I didn't try the nousb option.
Comment 15 Karl Hansen 2005-03-03 21:19:03 EST
After the latest version .770 failed to work, I started looking for other
potential USB problem sources.  After pulling the motherboard connections to the
front USB connector the system boots.  Before this is dismissed as just being a
hardware problem, I should point out that Windows 2000 runs with this indicated
as a non-functioning port and pre-10 series kernels ran aswell.  With the number
of USB ports present on what is not a "normal" computer (mine had 6) some fault
tolerance is probably in order.
Comment 16 Karl Hansen 2005-03-04 09:15:59 EST
I also had version .760 installed.  That now boots as well.  I suspect there is
a short in my computer's front USB panel.
Comment 17 mgm 2005-03-07 10:33:40 EST
Created attachment 111740 [details]
Chunk of /var/log/messages cooresponding to 2.6.10-770 boot and hang
Comment 18 mgm 2005-03-07 10:39:25 EST
Comment on attachment 111740 [details]
Chunk of /var/log/messages cooresponding to 2.6.10-770 boot and hang

Sorry, I screwed up adding my comments for the above attachment.  I continue to
get completely repeatable lockups (only power-cycle will reboot, can't
CTRL-ALT-F1  to get to vt1, no CTRL-ALT-DEL to reboot, etc.) with every 2.6.10
kernel (all the way up to 770) and 2.6.9 series works every time.  This is a
Compaq 1800T laptop, so no dangling USB wires or anything.  No usb devices
plugged inn for that matter.  Above is the chunk of /var/log/messages from the
last attempt to boot 2.6.10-1.770_FC3.
Comment 19 mgm 2005-03-15 17:43:30 EST
Ok, last night I tried passing acpi=off to the kernel in grub.conf and 2.6.10
kernels work fine.  Never had to do this with 2.6.9 kernels.  What changed with
Comment 20 Dave Jones 2005-07-15 16:49:06 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.