Bug 147315 - update festival to 1.9.5 (have preliminary rpms)
Summary: update festival to 1.9.5 (have preliminary rpms)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: festival (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-07 06:36 UTC by Matthew Miller
Modified: 2013-04-02 04:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-28 18:58:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthew Miller 2005-02-07 06:36:10 UTC
The 1.9.5 release of Festival offers significant improvements over the
current 1.4.x package. Particularly, from an end-user perspective, the
HTS (CMU "Arctic") voices sound much better than the previous ones,
and there's even *gasp* a female voice.

The release is backwards compatible with 1.4.3, so updating shouldn't
be  problem. And, this release is _basically_ what will be 2.0 --
they're only holding it up "until [they] can accommodate compatability
with newer versions of compilers". Since the current festival 1.4.3
package has in its changelog a comment about making it work with gcc
3.4, I don't think we have to worry about that -- so, this is
basically the same as what 2.0 will be.

It'd be nice to get it in before the upcoming FC4 freeze, if at all
possible.

I have preliminary packages at <http://www.mattdm.org/misc/festival/>,
which build and work on both FC2 and FC3. This should be a good
starting place for an FC-devel/FC4 package.

Comment 1 Matthew Miller 2005-02-07 06:41:17 UTC
Tomorrow, I'll work on integrating the suggestion from bug #75645
(don't put all that stuff in the bin directory). (Not really a blocker
for this bug, though....)

Comment 2 Matthew Miller 2005-02-07 19:31:58 UTC
Updated "0.mattdm8" release of this package moves utilities from
speech-tools out of the way, hopefully addressing the bug #75645 issue.

<http://www.mattdm.org/misc/festival/>

Another approach would be to split speech-tools into its own package
(it has its own source file, after all) and put all of these
special-purpose utils in a subpackage of that. (Maybe still not
installing into /usr/bin, to avoid conflicts with the various two- and
three-letter programs.)

Comment 3 Matthew Miller 2005-02-24 15:58:03 UTC
Any update on this?

Comment 4 Matthew Miller 2005-02-28 18:58:48 UTC
Cool -- package is in rawhide now. Thanks!


Note You need to log in before you can comment on or make changes to this bug.