Bug 75645 - Messes /usr/bin directory
Messes /usr/bin directory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: festival (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On: 156132
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2002-10-10 12:17 EDT by Enrico Scholz
Modified: 2013-03-13 00:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-09 15:48:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-10-10 12:17:54 EDT
Description of Problem:

festival places a lot of files into /usr/bin which are having common
names like 'align', having nothing to do with the core-functionality
(speech-synthesizer) of festival (e.g. 'build_docbook_index',
'cxx_to_docbook', 'example_to_doc++') or are very short and can be
used by other programs (e.g. 'dp', 'ols', 'pda', 'pm').

I suggest to move any program which is not intended for the user into
a /usr/lib/festival directory.


Version-Release number of selected component (if applicable):

festival-1.4.2-12
Comment 1 Matthew Miller 2005-02-06 23:48:10 EST
This is still the case in recent FC as well; updating bug version number.
Comment 2 Warren Togami 2005-02-07 01:33:38 EST
Isn't libexec a better place for executables not meant for end-users?
Comment 3 Matthew Miller 2005-02-07 01:42:11 EST
Yeah, libexec seems proper.

Tomorrow I'll work on doing this for my updated 1.9.5 packages (see
bug #147315).
Comment 4 Matthew Miller 2005-02-07 14:32:40 EST
Okay. Updated packages for bug #147315 should fix this. See there for
details.
Comment 5 Matthew Miller 2005-02-28 13:57:57 EST
The new package is in rawhide and should fix this.

Although, on inspection, /usr/bin/VCLocalRules seems to have crept into the
rawhide, and that looks like some sort of build control file. A description of
the file I found says "Deals with SIOD (Scheme In One Defun), a Scheme
interpreter." 

This means nothing to me. :) Does it to someone else?
Comment 6 Jonathan Blandford 2005-02-28 14:17:10 EST
SIOD was a scheme interpreter written in one day (Originally Scheme in one Day),
that was expanded to be extendable and 'Day' became 'Defun'.  It later was
rewritten and became guile.

Festival uses SIOD as an extension library.  I'm guessing that we don't need
that file, though.
Comment 7 John (J5) Palmieri 2005-04-27 15:46:27 EDT
I have the fix but it can't go out until I can get Festival to build on gcc-4.0

Note You need to log in before you can comment on or make changes to this bug.