Bug 1473179 - ovirt-engine-setup-plugin-dockerc is now deprecated
ovirt-engine-setup-plugin-dockerc is now deprecated
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Setup.Engine (Show other bugs)
4.1.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ovirt-4.1.5
: 4.1.5.2
Assigned To: Ido Rosenzwig
Gonza
: EasyFix
Depends On:
Blocks: 1473182
  Show dependency treegraph
 
Reported: 2017-07-20 04:01 EDT by Sandro Bonazzola
Modified: 2017-08-28 03:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Deprecated Functionality
Doc Text:
The ovirt-engine-setup-plugin-dockerc package is now deprecated, and will be removed in version 4.2.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-23 04:03:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
sbonazzo: devel_ack+
lsvaty: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 79642 master ABANDONED packaging: setup: Add dockerc plugin deprecation warning 2017-08-07 02:09 EDT
oVirt gerrit 80312 ovirt-engine-4.1 MERGED packaging: setup: Add dockerc plugin deprecation warning 2017-08-07 04:01 EDT

  None (edit)
Description Sandro Bonazzola 2017-07-20 04:01:47 EDT
Mark ovirt-engine-setup-plugin-dockerc as deprecated by adding a warning it will be dropped in 4.2.
The plugin is obsolete and has been in tech preview for a while without being promoted to fully supported feature.
Comment 1 Gonza 2017-08-18 05:20:42 EDT
Verified with:
ovirt-engine-setup-4.1.5.3-0.0.master.20170815115046.git41c45b8.el7.centos.noarch

# engine-setup
[ INFO  ] Stage: Initializing
[ INFO  ] Stage: Environment setup
...
          --== PRODUCT OPTIONS ==--
         
          Please note: container deployment will be deprecated on 4.2
          Deploy Cinder container on this host (Yes, No) [Yes]: 
          Please note: container deployment will be deprecated on 4.2
          Deploy Glance container on this host (Yes, No) [Yes]: 
...

Note You need to log in before you can comment on or make changes to this bug.