Bug 1473386 - rebase nfs-ganesha to 2.5
Summary: rebase nfs-ganesha to 2.5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 3.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 3.0
Assignee: Ken Dreyer (Red Hat)
QA Contact: vidushi
Bara Ancincova
URL:
Whiteboard:
: 1475024 (view as bug list)
Depends On:
Blocks: 1494421
TreeView+ depends on / blocked
 
Reported: 2017-07-20 16:38 UTC by Ken Dreyer (Red Hat)
Modified: 2017-12-05 23:36 UTC (History)
13 users (show)

Fixed In Version: RHEL: nfs-ganesha-2.5.2-1.el7cp Ubuntu: nfs-ganesha_2.5.2-2redhat1xenial
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
.`nfs-ganesha` rebased to 2.5 The `nfs-ganesha` package has been upgraded to upstream version 2.5, which provides a number of bug fixes and enhancements over the previous version.
Clone Of:
Environment:
Last Closed: 2017-12-05 23:36:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github ceph ceph pull 16275 None None None 2017-07-20 22:11:23 UTC
Red Hat Product Errata RHBA-2017:3387 normal SHIPPED_LIVE Red Hat Ceph Storage 3.0 bug fix and enhancement update 2017-12-06 03:03:45 UTC

Description Ken Dreyer (Red Hat) 2017-07-20 16:38:04 UTC
Description of problem:
RH Ceph Storage 2 shipped nfs-ganesha 2.4, and we want to ship 2.5 to stay close to upstream.

Steps to Reproduce:
1. Install nfs-ganesha following the documentation
2. Run "ganesha.nfsd -v" to check the version number

Expected results:
"-v" prints 2.5 something

Comment 1 Ken Dreyer (Red Hat) 2017-07-20 22:11:23 UTC
nfs-ganesha 2.5.0.4 requires https://github.com/ceph/ceph/pull/16275

Comment 9 Matt Benjamin (redhat) 2017-08-30 18:50:46 UTC
*** Bug 1475024 has been marked as a duplicate of this bug. ***

Comment 16 Ken Dreyer (Red Hat) 2017-10-19 13:28:11 UTC
LGTM, thanks

Comment 19 errata-xmlrpc 2017-12-05 23:36:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387


Note You need to log in before you can comment on or make changes to this bug.