Bug 1473423 - Fedora 26 ignores search domain set in network manager
Fedora 26 ignores search domain set in network manager
Status: CLOSED DUPLICATE of bug 1470966
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
26
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-20 14:53 EDT by Eric Mesa
Modified: 2017-07-25 10:40 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-25 10:35:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Mesa 2017-07-20 14:53:19 EDT
Description of problem:

I upgraded a laptop from Fedora 25 to Fedora 26. For the connection, I have a domain name specified in seach domain: "mushroomkingdom". In Fedora 25 I could do the following:

ssh root@luigi

and it would work. But now it doesn't work. Now I have to type

ssh root@luigi.mushroomkingdom

Did Fedora change where the info is stored so that it still shows in network manager, but isn't being read anymore?


Version-Release number of selected component (if applicable):


How reproducible:

Try to ping or ssh without including the domain name and an error is given. But include the domain name and it works.


Steps to Reproduce:
1. ssh root@luigi
2. get error
3.

Actual results:

Computer complains it doesn't know what I'm sshing into

Expected results:

ssh into the computer I am specifying

Additional info:

Another mention that this happens from an upgrade. Not sure if it happens on fresh install.
Comment 1 Beniamino Galvani 2017-07-20 16:51:36 EDT
This is probably a duplicate of bug 1470966.

Which NM version do you have? Can you try updating to the latest version?

What's the content of /etc/resolv.conf ?
Comment 2 Beniamino Galvani 2017-07-25 10:35:11 EDT

*** This bug has been marked as a duplicate of bug 1470966 ***
Comment 3 Beniamino Galvani 2017-07-25 10:40:59 EDT
The issue should be fixed in NetworkManager-1.8.2-1.fc26, please reopen if needed.

Note You need to log in before you can comment on or make changes to this bug.