Bug 147349 - errata version of Quota no longer supports old RPC quota version
errata version of Quota no longer supports old RPC quota version
Status: CLOSED DUPLICATE of bug 144109
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: quota (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Feist
Brock Organ
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-07 10:46 EST by Richard Cunningham
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Cunningham 2005-02-07 10:46:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
After updating to the quota-3.10-4 package we are unable to use quotas
with our Solaris 7 & 8 NFS servers.



Version-Release number of selected component (if applicable):
quota-3.10-4

How reproducible:
Always

Steps to Reproduce:
1. update to quota-3.10-4
2. Try to use it with Solaris 7 or 8 NFS server.

Actual Results:  $ quota -v
quota: Error while getting quota from nfsserver:/export/dcs/sys for
32570: Invalid argument
Disk quotas for user rjc (uid 32570): none


Expected Results:  $ quota -v
Disk quotas for user rjc (uid 32570):
     Filesystem  blocks   quota   limit   grace   files   quota  
limit   grace
nfsserver:/export/dcs/sys
                      0       0       0               0       0       0

Additional info:

It sounds support for RPC quota version 1 was broken upstream in 3.10
and fixed again 3.11
http://sourceforge.net/project/shownotes.php?release_id=216575
Solaris 7 & 8 only support quota version 1:

$ rpcinfo -p nfsserver |grep quota
    100011    1   udp  32916  rquotad
Comment 2 Chris Feist 2005-02-07 17:36:29 EST
This is a dup of bz #144109, the fix will be in quota-3.10-5.

*** This bug has been marked as a duplicate of 144109 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:08:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.