Bug 1473781 - virt-who fails with KeyError: 'major' error when connected to RHEV4
virt-who fails with KeyError: 'major' error when connected to RHEV4
Status: CLOSED DUPLICATE of bug 1444701
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscriptions - virt-who (Show other bugs)
6.2.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Barnaby Court
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-21 12:01 EDT by Konstantin Trufanov
Modified: 2017-07-25 05:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-24 08:36:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Konstantin Trufanov 2017-07-21 12:01:00 EDT
Description of problem:

virt-who throw the following exception

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/virtwho/virt/virt.py", line 387, in run
    self._run()
  File "/usr/lib/python2.7/site-packages/virtwho/virt/virt.py", line 421, in _run
    self.prepare()
  File "/usr/lib/python2.7/site-packages/virtwho/virt/rhevm/rhevm.py", line 80, in prepare
    self.get_version()
  File "/usr/lib/python2.7/site-packages/virtwho/virt/rhevm/rhevm.py", line 124, in get_version
    major = version.attrib['major']
KeyError: 'major'


Version-Release number of selected component (if applicable):

1.19 from rhel-7-server-satellite-tools-6.2-rpms

How reproducible:

All the time

Steps to Reproduce:
1. update virt-who to latest version from rhel-7-server-satellite-tools-6.2-rpms
2. run it within the following configuration as an example
[rhev-prod-test]
type=rhevm
##server=https://segotl2598.got.volvo.neta:443/ovirt-engine/
server=https://192.168.111.10:443/ovirt-engine/
username=admin@internal
password=RedHat1!
owner=Default_Organization
#owner=1
env=Library
hypervisor_id=hostname
rhsm_hostname=provisioning.sysmgmt.lan
rhsm_username=virtwho
rhsm_password=virtwho
rhsm_prefix=/rhsm
3. get the error

Actual results:

virt-who crash

Expected results:

virt-who reports to Satellite/Customer portal
Comment 1 Eko 2017-07-24 08:36:58 EDT

*** This bug has been marked as a duplicate of bug 1444701 ***

Note You need to log in before you can comment on or make changes to this bug.