Bug 1474180 - [Scale] : Client logs flooded with "inode context is NULL" error messages
[Scale] : Client logs flooded with "inode context is NULL" error messages
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: io-cache (Show other bugs)
mainline
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: bugs@gluster.org
:
Depends On: 1473229
Blocks: 1475635 1475637 1475638
  Show dependency treegraph
 
Reported: 2017-07-24 01:29 EDT by Poornima G
Modified: 2017-12-08 12:35 EST (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.13.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1473229
: 1475635 1475637 1475638 (view as bug list)
Environment:
Last Closed: 2017-12-08 12:35:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Worker Ant 2017-07-24 01:33:24 EDT
REVIEW: https://review.gluster.org/17855 (io-cache: Do not error out if inode_ctx is NULL) posted (#2) for review on master by Poornima G (pgurusid@redhat.com)
Comment 2 Worker Ant 2017-07-26 02:39:27 EDT
REVIEW: https://review.gluster.org/5029 (performance/io-cache: update inode contexts of each entry in readdirplus) posted (#5) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 3 Worker Ant 2017-07-26 03:07:34 EDT
REVIEW: https://review.gluster.org/5029 (performance/io-cache: update inode contexts of each entry in readdirplus) posted (#6) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 4 Worker Ant 2017-07-26 23:58:14 EDT
COMMIT: https://review.gluster.org/5029 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit b90e12134af85635199750967c326761d6c06e86
Author: Raghavendra G <raghavendra@gluster.com>
Date:   Fri May 17 12:52:32 2013 +0530

    performance/io-cache: update inode contexts of each entry in readdirplus
    
    io-cache stores read-cache in inode which is currently created only in
    lookup. But, with readdirplus and md-cache absorbing lookups, io-cache
    need not receive a lookup before a fop like readv.
    
    Change-Id: I6eba995b0a90d4d5055a4aef0489707b852da1b8
    BUG: 1474180
    Signed-off-by: Raghavendra G <raghavendra@gluster.com>
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-on: https://review.gluster.org/5029
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
Comment 5 Shyamsundar 2017-12-08 12:35:17 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.13.0, please open a new bug report.

glusterfs-3.13.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-December/000087.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.