Bug 1475637 - [Scale] : Client logs flooded with "inode context is NULL" error messages
[Scale] : Client logs flooded with "inode context is NULL" error messages
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: io-cache (Show other bugs)
3.11
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: bugs@gluster.org
:
Depends On: 1474180 1473229 1475638
Blocks: 1475635
  Show dependency treegraph
 
Reported: 2017-07-27 00:03 EDT by Raghavendra G
Modified: 2017-08-24 10:46 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.11.3
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1474180
Environment:
Last Closed: 2017-08-24 10:46:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Worker Ant 2017-07-27 00:05:26 EDT
REVIEW: https://review.gluster.org/17890 (performance/io-cache: update inode contexts of each entry in readdirplus) posted (#1) for review on release-3.11 by Raghavendra G (rgowdapp@redhat.com)
Comment 2 Worker Ant 2017-07-31 10:11:20 EDT
COMMIT: https://review.gluster.org/17890 committed in release-3.11 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 9d8841f96afd351624f5c805321053842405b038
Author: Raghavendra G <raghavendra@gluster.com>
Date:   Fri May 17 12:52:32 2013 +0530

    performance/io-cache: update inode contexts of each entry in readdirplus
    
    io-cache stores read-cache in inode which is currently created only in
    lookup. But, with readdirplus and md-cache absorbing lookups, io-cache
    need not receive a lookup before a fop like readv.
    
    >Change-Id: I6eba995b0a90d4d5055a4aef0489707b852da1b8
    >BUG: 1474180
    >Signed-off-by: Raghavendra G <raghavendra@gluster.com>
    >Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    >Reviewed-on: https://review.gluster.org/5029
    >Smoke: Gluster Build System <jenkins@build.gluster.org>
    >CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    
    (cherry picked from commit b90e12134af85635199750967c326761d6c06e86)
    Change-Id: I6eba995b0a90d4d5055a4aef0489707b852da1b8
    BUG: 1475637
    Signed-off-by: Raghavendra G <raghavendra@gluster.com>
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-on: https://review.gluster.org/17890
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
Comment 3 Shyamsundar 2017-08-24 10:46:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.3, please open a new bug report.

glusterfs-3.11.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-August/000081.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.