Bug 1474299 - Log tool can not be started as user (no password entry request)
Log tool can not be started as user (no password entry request)
Status: CLOSED DUPLICATE of bug 1487248
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-system-log (Show other bugs)
7.4
All All
medium Severity medium
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-24 06:58 EDT by Oliver Haessler
Modified: 2017-09-08 13:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-08 13:23:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Haessler 2017-07-24 06:58:12 EDT
Description of problem:
Starting gnome-system-log from a Gnome 3 User session produces error in log file but does not ask for the root password.

Version-Release number of selected component (if applicable):
gnome-system-log-3.9.90-3.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. Start RHEL 7.4 with a user logged in to Gnome 3 session
2. press "Windows" key and type "log"
3. Star the "System Log" tool

Actual results:
no root password request and error in journalctl:

Jul 24 12:50:57 xxxx gnome-system-log.desktop[15359]: Refusing to render service to dead parents.
Jul 24 12:51:01 xxxx tracker-extract[4830]: unable to create file '/run/user/14685/dconf/user': Permission denied.  dconf will not work properly.


Expected results:
gnome-system-log


Additional Info:
Starting journalctl from the terminal as user shows the following warning:

Hint: You are currently not seeing messages from other users and the system.
      Users in groups 'adm', 'systemd-journal', 'wheel' can see all messages.
      Pass -q to turn off this notice.

but shows my log entries for my user. Would be cool if Gnome System log would do the same, so users can look into issues and error messages more easy.
Comment 2 Ray Strode [halfline] 2017-09-08 13:23:41 EDT

*** This bug has been marked as a duplicate of bug 1487248 ***

Note You need to log in before you can comment on or make changes to this bug.