Bug 1474429 - controller-manager panic/crash on volume verification
controller-manager panic/crash on volume verification
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.6.z
Assigned To: Hemant Kumar
Jianwei Hou
:
Depends On:
Blocks: 1474441 1474431
  Show dependency treegraph
 
Reported: 2017-07-24 11:14 EDT by Hemant Kumar
Modified: 2017-10-25 09:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1474431 1474441 (view as bug list)
Environment:
Last Closed: 2017-10-25 09:04:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hemant Kumar 2017-07-24 11:14:09 EDT
As per https://github.com/kubernetes/kubernetes/issues/49418 controller-manager can crash in certain cases when volume spec present in attach/detach controller becomes nil. We need to cherry-pick the fix to 1.6 release.
Comment 1 Hemant Kumar 2017-07-25 13:57:34 EDT
PR - https://github.com/openshift/ose/pull/807
Comment 6 Jianwei Hou 2017-10-17 21:12:10 EDT
Tested with the advisory version and there are no regressions.
Comment 8 errata-xmlrpc 2017-10-25 09:04:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3049

Note You need to log in before you can comment on or make changes to this bug.