Bug 1474431 - controller-manager panic/crash on volume verification
controller-manager panic/crash on volume verification
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage (Show other bugs)
3.5.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.5.z
Assigned To: Hemant Kumar
Jianwei Hou
:
Depends On: 1474429 1474441
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-24 11:17 EDT by Hemant Kumar
Modified: 2017-08-31 13:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1474429
Environment:
Last Closed: 2017-08-31 13:00:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hemant Kumar 2017-07-24 11:17:24 EDT
+++ This bug was initially created as a clone of Bug #1474429 +++

As per https://github.com/kubernetes/kubernetes/issues/49418 controller-manager can crash in certain cases when volume spec present in attach/detach controller becomes nil. We need to cherry-pick the fix to 1.6 release.
Comment 1 Hemant Kumar 2017-07-25 13:58:08 EDT
https://github.com/openshift/ose/pull/809
Comment 3 Jianwei Hou 2017-08-08 23:32:40 EDT
Tested on v3.5.5.31.15

There are no regression bugs found for the fix. The controller manager crash issue is not seen.
Comment 5 errata-xmlrpc 2017-08-31 13:00:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1828

Note You need to log in before you can comment on or make changes to this bug.