Bug 1474631 - [qla4xxx iscsi] kdump failure when use iscsi device as dump target
[qla4xxx iscsi] kdump failure when use iscsi device as dump target
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kexec-tools (Show other bugs)
7.5
x86_64 Unspecified
medium Severity medium
: rc
: ---
Assigned To: Xunlei Pang
Qiao Zhao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-25 01:32 EDT by Qiao Zhao
Modified: 2018-04-10 10:12 EDT (History)
5 users (show)

See Also:
Fixed In Version: kexec-tools-2.0.14-18.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 10:10:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0807 None None None 2018-04-10 10:12 EDT

  None (edit)
Description Qiao Zhao 2017-07-25 01:32:10 EDT
Description of problem:

According another bug comments https://bugzilla.redhat.com/show_bug.cgi?id=1265046#c11
Kdump failed on machine storageqe-81 when use *san boot* iscsi device as dump target.

Here is part of the log:

[   34.537003] qla4xxx 0000:07:00.5: qla4xxx_isr_decode_mailbox: LINK UP
[   34.550003] scsi1: AEN 8029, mbox_sts[2]=0003, mbox_sts[3]=0005
[   34.761011]  QLogic iSCSI HBA Driver version: 5.04.00.00.07.02-k0
[   34.761011]   QLogic ISP8022 @ 0000:07:00.5, host#=1, fw=04.20.01.1019
[   94.769182] qla4xxx 0000:07:00.5: scsi1: Mailbox Cmd 0x00000059 timed out, Scheduling Adapter Reset
[   94.772217] qla4xxx 0000:07:00.5: disabling pause transmit on port 0 & 1.
[   94.774545] qla4xxx 0000:07:00.5: qla4_8xxx_set_param: failed status FFFFFFFF
[   94.776912] qla4xxx 0000:07:00.5: get_fw_boot_info: Get FW boot info for 0x8022 func 5
[   97.886401] qla4xxx 0000:07:00.5: HW State: NEED RESET
[   97.888069] qla4xxx 0000:07:00.5: Device state is 0x4 = Need Reset
[   97.890068] qla4xxx 0000:07:00.5: Performing ISP error recovery
[   97.891978] qla4xxx 0000:07:00.5: qla4_82xx_need_reset_handler(1): drv_state = 0x0, drv_active = 0x110011
[   97.895000] qla4xxx 0000:07:00.5: qla4_82xx_need_reset_handler(1): drv_state = 0x0, drv_active = 0x110011
[   98.252422] qla4xxx 0000:07:00.4: qla4_8xxx_watchdog: HW State: NEED RESET!
[ TIME ] Timed out waiting for device dev-mapper-mpatha1.device.
[DEPEND] Dependency failed for File System Check on /dev/mapper/mpatha1.
[DEPEND] Dependency failed for /kdumproot/boot.
[DEPEND] Dependency failed for Remote File Systems.
         Starting dracut pre-pivot and cleanup hook...
[   98.898468] qla4xxx 0000:07:00.5: qla4_82xx_need_reset_handler(1): drv_state = 0x11, drv_active = 0x110011
[   99.902538] qla4xxx 0000:07:00.5: qla4_82xx_need_reset_handler(1): drv_state = 0x11, drv_active = 0x110011
[  100.906608] qla4xxx 0000:07:00.5: qla4_82xx_need_reset_handler(1): drv_state = 0x11, drv_active = 0x110011
[  101.254635] qla4xxx 0000:07:00.4: HW State: DEVICE INITIALIZING
[  101.256643] qla4xxx 0000:07:00.4: Device state is 0x4 = Need Reset
[  101.258660] qla4xxx 0000:07:00.4: Performing ISP error recovery
[  101.260608] qla4xxx 0000:07:00.4: qla4_8xxx_set_rst_ready(0): drv_state: 0x00010011
[  101.263087] qla4xxx 0000:07:00.4: qla4_82xx_need_reset_handler(0): drv_state = 0x10011, drv_active = 0x110011
[  101.910679] qla4xxx 0000:07:00.5: Device state is 0x4 = Need Reset
[  101.912746] qla4xxx 0000:07:00.5: HW State: COLD/RE-INIT
[  101.914506] qla4xxx 0000:07:00.5: qla4_8xxx_set_rst_ready(1): drv_state: 0x00110011
<snip>
[  169.819672] random: crng init done
         Starting File System Check on /dev/mapper/mpatha1...
[  167.117611] systemd-fsck[381]: /sbin/fsck.xfs: XFS file system.
[  OK  ] Started File System Check on /dev/mapper/mpatha1.
         Mounting /kdumproot/boot...
[  170.057188] SGI XFS with ACLs, security attributes, no debug enabled
[  OK  ] Started dracut[  170.067913] XFS (dm-1): Mounting V5 Filesystem
 pre-pivot and cleanup hook.
         Starting Kdump Vmcore Save Service...
kdump: dump target is
kdump: error: Dump target  is not mounted.
kdump: saving vmcore failed
[FAILED] Failed to start Kdump Vmcore Save Service.


Other information in here:

[root@storageqe-81 ~]# grep -v ^# /etc/kdump.conf

path /boot
core_collector makedumpfile -l --message-level 1 -d 31

[root@storageqe-81 ~]# lsblk 
NAME                          MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda                             8:0    0 232.9G  0 disk  
sdb                             8:16   0    50G  0 disk  
└─mpatha                      253:0    0    50G  0 mpath 
  ├─mpatha1                   253:1    0     1G  0 part  /boot
  └─mpatha2                   253:2    0    49G  0 part  
    ├─rhel_storageqe--81-root 253:3    0    44G  0 lvm   /
    └─rhel_storageqe--81-swap 253:4    0     5G  0 lvm   [SWAP]
sdc                             8:32   0    50G  0 disk  
└─mpatha                      253:0    0    50G  0 mpath 
  ├─mpatha1                   253:1    0     1G  0 part  /boot
  └─mpatha2                   253:2    0    49G  0 part  
    ├─rhel_storageqe--81-root 253:3    0    44G  0 lvm   /
    └─rhel_storageqe--81-swap 253:4    0     5G  0 lvm   [SWAP]
sdd                             8:48   0 465.8G  0 disk  
sde                             8:64   0 465.8G  0 disk  
sr0                            11:0    1  1024M  0 rom   


[root@storageqe-81 ~]# multipath -l
mpatha (360fff19abdd9c5c6753155d351262a2b) dm-0 EQLOGIC ,100E-00         
size=50G features='0' hwhandler='0' wp=rw
|-+- policy='service-time 0' prio=0 status=active
| `- 4:0:0:0 sdc 8:32 active undef unknown
`-+- policy='service-time 0' prio=0 status=enabled
  `- 5:0:0:0 sdb 8:16 active undef unknown


[root@storageqe-81 ~]# iscsiadm -m session
qla4xxx: [1] 10.34.80.11:3260,1 iqn.2001-05.com.equallogic:0-af1ff6-c6c5d9bd9-2b2a2651d3553175-storageqe-81-boot (flash)
qla4xxx: [2] 10.34.80.11:3260,1 iqn.2001-05.com.equallogic:0-af1ff6-c6c5d9bd9-2b2a2651d3553175-storageqe-81-boot (flash)


Version-Release number of selected component (if applicable):
kernel-3.10.0-693.el7.x86_64
kexec-tools-2.0.14-17.el7.x86_64
dracut-033-502.el7.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 6 errata-xmlrpc 2018-04-10 10:10:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0807

Note You need to log in before you can comment on or make changes to this bug.