Bug 1474697 - OSP11 -> OSP12 upgrade: ability to upgrade individual nodes on split stack deployments
OSP11 -> OSP12 upgrade: ability to upgrade individual nodes on split stack de...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
high Severity urgent
: rc
: 12.0 (Pike)
Assigned To: Marios Andreou
Marius Cornea
: Triaged
Depends On:
Blocks: 1399762
  Show dependency treegraph
 
Reported: 2017-07-25 03:46 EDT by Marius Cornea
Modified: 2018-02-05 14:10 EST (History)
12 users (show)

See Also:
Fixed In Version: openstack-tripleo-common-7.6.3-0.20171022171807.f27b723.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-13 16:44:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1718657 None None None 2017-09-21 08:46 EDT
OpenStack gerrit 509797 None None None 2017-10-05 10:49 EDT

  None (edit)
Description Marius Cornea 2017-07-25 03:46:26 EDT
Description of problem:
On split stack deployments "openstack server list" is empty as there are no nodes deployed by TripleO. With the upgrade workflow, when upgrading individual nodes such as compute or swift object storage nodes, we need to point them by name/UUID to the upgrade non controller script. 

In order to be able to upgrade such nodes in a split stack deployment we need the ability to reference them in a different way, perhaps by IP address.

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-7.0.0-0.20170718190543.el7ost.noarch.rpm

How reproducible:
100%
Comment 2 Marios Andreou 2017-09-18 06:17:59 EDT
going to take this one @matbu (about to ping you on irc too) I think for P/12 we need to update the upgrade-non-controller.sh to take the IP address (for example? I will discuss with mcornea some more) as we are using BZ 1477962 for the non-controller upgrade workflow (see comment at https://bugs.launchpad.net/tripleo/+bug/1708115/comments/8 for info on the core workflow we are using in P - I think 'proper' upgrade support in mistral/tripleoclient/tripleo-common is coming in Q see https://etherpad.openstack.org/p/tripleo-ptg-queens-upgrades )
Comment 3 Marios Andreou 2017-09-21 08:48:33 EDT
added a review to the trackers https://review.openstack.org/505624 this will accept an IP address as well as nova name/uuid. Still not clear if we get the inventory though but testing will show that.
Comment 4 Marius Cornea 2017-10-16 17:43:34 EDT
I tried running the upgrade-non-controller script on a split stack deployment but it prompts for a password:

(undercloud) [stack@undercloud-0 ~]$ upgrade-non-controller.sh --upgrade 192.168.0.60
Mon Oct 16 17:41:11 EDT 2017 upgrade-non-controller.sh Logging to upgrade-non-controller.sh-192.168.0.60
No server with a name or ID of '192.168.0.60' exists.
Mon Oct 16 17:41:12 EDT 2017 upgrade-non-controller.sh 192.168.0.60 not known to nova. Trying it as an IP address
PING 192.168.0.60 (192.168.0.60) 56(84) bytes of data.
64 bytes from 192.168.0.60: icmp_seq=1 ttl=64 time=0.367 ms

--- 192.168.0.60 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.367/0.367/0.367/0.000 ms
Warning: Permanently added '192.168.0.60' (ECDSA) to the list of known hosts.
heat-admin@192.168.0.60's password: 


Note that as we describe in the docs the user is required to add the 'stack' user:
https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/11/html/director_installation_and_usage/chap-configuring_basic_overcloud_requirements_on_pre_provisioned_nodes
Comment 5 Marius Cornea 2017-10-16 17:50:23 EDT
I filed bug 1502874 to keep track of this ass it's a different issue than what this ticket is tracking.
Comment 6 Marios Andreou 2017-10-17 01:40:37 EDT
(In reply to Marius Cornea from comment #4)
> I tried running the upgrade-non-controller script on a split stack
> deployment but it prompts for a password:
> 
> (undercloud) [stack@undercloud-0 ~]$ upgrade-non-controller.sh --upgrade
> 192.168.0.60
> Mon Oct 16 17:41:11 EDT 2017 upgrade-non-controller.sh Logging to
> upgrade-non-controller.sh-192.168.0.60
> No server with a name or ID of '192.168.0.60' exists.
> Mon Oct 16 17:41:12 EDT 2017 upgrade-non-controller.sh 192.168.0.60 not
> known to nova. Trying it as an IP address
> PING 192.168.0.60 (192.168.0.60) 56(84) bytes of data.
> 64 bytes from 192.168.0.60: icmp_seq=1 ttl=64 time=0.367 ms
> 
> --- 192.168.0.60 ping statistics ---
> 1 packets transmitted, 1 received, 0% packet loss, time 0ms
> rtt min/avg/max/mdev = 0.367/0.367/0.367/0.000 ms
> Warning: Permanently added '192.168.0.60' (ECDSA) to the list of known hosts.
> heat-admin@192.168.0.60's password: 
> 
> 
> Note that as we describe in the docs the user is required to add the 'stack'
> user:
> https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/11/
> html/director_installation_and_usage/chap-
> configuring_basic_overcloud_requirements_on_pre_provisioned_nodes


ack  I replied on the other BZ you filed https://bugzilla.redhat.com/show_bug.cgi?id=1502874#c1 (there is an override wired in you can try)
Comment 12 errata-xmlrpc 2017-12-13 16:44:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Note You need to log in before you can comment on or make changes to this bug.