Bug 1474806 - A Floating IP of one tenant can be associated with a port belonging to another tenant
A Floating IP of one tenant can be associated with a port belonging to anothe...
Status: CLOSED DUPLICATE of bug 1480269
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
high Severity high
: Upstream M3
: 12.0 (Pike)
Assigned To: Assaf Muller
Toni Freger
: AutomationBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-25 08:19 EDT by Itzik Brown
Modified: 2017-08-23 08:27 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-23 08:25:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1706328 None None None 2017-07-25 08:19 EDT

  None (edit)
Description Itzik Brown 2017-07-25 08:19:11 EDT
Description of problem:

The following test fails:
neutron.tests.tempest.api.admin.test_floating_ips_admin_actions.FloatingIPAdminTestJSON.test_associate_floating_ip_with_port_from_another_tenant

Traceback (most recent call last):
  File "/home/centos/tempest-upstream/neutron/neutron/tests/tempest/api/admin/test_floating_ips_admin_actions.py", line 64, in test_associate_floating_ip_with_port_from_another_tenant
    self.assertRaises(lib_exc.BadRequest,
  File "/home/centos/tempest-upstream/lib/python2.7/site-packages/testtools/testcase.py", line 485, in assertRaises
    self.assertThat(our_callable, matcher)
  File "/home/centos/tempest-upstream/lib/python2.7/site-packages/testtools/testcase.py", line 498, in assertThat
    raise mismatch_error
testtools.matchers._impl.MismatchError: <function _update at 0x5f3ae60> returned {u'floatingip': {u'router_id': u'2be3c4b2-38b3-4bc8-acda-26fbab475ea2', u'status': u'ACTIVE', u'description': u'', u'tenant_id': u'f0cbe309a7c244b0a9356fbb7c9dd530', u'created_at': u'2017-07-25T09:43:34Z', u'updated_at': u'2017-07-25T09:50:19Z', u'floating_network_id': u'34899a2a-7a5c-447d-8a7f-cc7d70b56ec8', u'fixed_ip_address': u'10.100.0.11', u'floating_ip_address': u'10.6.66.15', u'revision_number': 2, u'project_id': u'f0cbe309a7c244b0a9356fbb7c9dd530', u'port_id': u'c30c8136-1a9c-4c64-bfbb-02f2c19abf2d', u'id': u'32f3320c-c7af-4d56-9cc9-e973f18c6893'}}

A manual associating of a floating IP of one tenant to a port's of another tenant worked as well.

Version-Release number of selected component (if applicable):
python-networking-odl-11.0.0-0.20170714110903.cd46f2f.el7ost.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 5 Jakub Libosvar 2017-08-23 08:25:04 EDT
Even though this BZ is older, the fix is tracked in Neutron as part of bug 1480269, so I'm closing this one as duplicate.

*** This bug has been marked as a duplicate of bug 1480269 ***

Note You need to log in before you can comment on or make changes to this bug.