Bug 1480269 - neutron API test "test_associate_floating_ip_with_port_from_another_tenant" fails
neutron API test "test_associate_floating_ip_with_port_from_another_tenant" f...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
high Severity high
: beta
: 12.0 (Pike)
Assigned To: Jakub Libosvar
Toni Freger
: AutomationBlocker, Triaged
: 1474806 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-10 10:41 EDT by Arie Bregman
Modified: 2018-02-05 14:12 EST (History)
10 users (show)

See Also:
Fixed In Version: openstack-neutron-11.0.2-0.20171020230400.dde92f0.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-13 16:51:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 493877 None None None 2017-08-15 09:48 EDT
OpenStack gerrit 495864 None None None 2017-08-23 08:28 EDT
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-15 20:43:25 EST

  None (edit)
Description Arie Bregman 2017-08-10 10:41:00 EDT
Description of problem:

The following test fails when running tests on OSP 12 HA deployment

neutron.tests.tempest.api.admin.test_floating_ips_admin_actions.FloatingIPAdminTestJSON.test_associate_floating_ip_with_port_from_another_tenant


Version-Release number of selected component (if applicable):

openstack-neutron-11.0.0-0.20170804190460.el7ost.noarch

How reproducible: 100%


Steps to Reproduce:
1. Deploy OSP 12 HA
2. Run neutron API tests

Actual results:

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/neutron/tests/tempest/api/admin/test_floating_ips_admin_actions.py", line 65, in test_associate_floating_ip_with_port_from_another_tenant
    floating_ip['id'], port_id=port['port']['id'])
  File "/usr/lib/python2.7/site-packages/testtools/testcase.py", line 422, in assertRaises
    self.assertThat(our_callable, matcher)
  File "/usr/lib/python2.7/site-packages/testtools/testcase.py", line 435, in assertThat
    raise mismatch_error
testtools.matchers._impl.MismatchError: <function _update at 0x6607de8> returned {u'floatingip': {u'router_id': u'e255dca3-5dfe-452d-bbbc-d73af9bd43f8', u'status': u'DOWN', u'description': u'', u'tags': [], u'tenant_id': u'd0232ced5d4d4238876a748fc06b3fcc', u'created_at': u'2017-08-10T10:56:49Z', u'updated_at': u'2017-08-10T10:56:55Z', u'floating_network_id': u'9f499f7b-6147-4e68-a05a-f621ce725223', u'fixed_ip_address': u'10.100.0.7', u'floating_ip_address': u'10.0.0.211', u'revision_number': 1, u'project_id': u'd0232ced5d4d4238876a748fc06b3fcc', u'port_id': u'fdec4851-c670-4132-ac38-78a03d986ed0', u'id': u'2c621ccf-418b-49cf-bb45-46c7e3e6d0f0'}}



Expected results: All tests passed successfully


Additional info:
Comment 2 Jakub Libosvar 2017-08-10 12:19:36 EDT
I looked at upstream jobs and we skip it as we don't run Identity service with admin v2 API anymore and this test doesn't support v3 yet. Please check tempest.conf for 

[identity-feature-enabled]
api_v2_admin = True

and if keystone is really configured that way.
Comment 3 Jakub Libosvar 2017-08-10 12:20:03 EDT
(In reply to Jakub Libosvar from comment #2)
> I looked at upstream jobs and we skip it as we don't run Identity service
> with admin v2 API anymore and this test doesn't support v3 yet. Please check
> tempest.conf for 
> 
> [identity-feature-enabled]
> api_v2_admin = True
> 
> and if keystone is really configured that way.

If not, just set it to False and it should be skipped just like in upstream :)
Comment 4 Jakub Libosvar 2017-08-10 15:17:57 EDT
I checked the tempest.conf and all services are set with api_v2_admin = True. Note that v2 has been deprecated since Mitaka (OSP9) - https://blueprints.launchpad.net/keystone/+spec/deprecated-as-of-mitaka
Comment 5 Chandan Kumar 2017-08-11 10:33:32 EDT
Hello Jakub,

Currently as a workaround in the ci jobs, We can pass identity-featured-enabled.api_v2_admin False as an argument with discover-tempest-config, can override the value till we fix it in python-tempestconf in a better way for identity v2 and v3 api.

Thanks,

Chandan Kumar
Comment 6 Ihar Hrachyshka 2017-08-11 14:37:27 EDT
Does TripleO configure keystone for v2? If so, the test should still pass. The fact that it's not executed in upstream gate is probably tangential to the issue. Otherwise, it's a bug in python-tempestconf and we should change the bug component to match that fact.
Comment 8 Chandan Kumar 2017-08-11 15:18:34 EDT
Hello Ihar,

(In reply to Ihar Hrachyshka from comment #6)
> Does TripleO configure keystone for v2? 
Yup, Tripleo stills configures Keystone V2 api. The tripleo does not switched to v3 as mistral does not work with v3 api.

Thanks,

Chandan Kumar
Comment 10 Jakub Libosvar 2017-08-23 08:25:04 EDT
*** Bug 1474806 has been marked as a duplicate of this bug. ***
Comment 16 errata-xmlrpc 2017-12-13 16:51:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Note You need to log in before you can comment on or make changes to this bug.