Bug 1474852 - hiding icons on desktop does not work
Summary: hiding icons on desktop does not work
Keywords:
Status: CLOSED DUPLICATE of bug 1460768
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-tweak-tool
Version: 7.4
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: 7.8
Assignee: Milan Crha
QA Contact: Desktop QE
Lucie Maňásková
URL:
Whiteboard:
Depends On:
Blocks: 1679127 1738389
TreeView+ depends on / blocked
 
Reported: 2017-07-25 13:56 UTC by Tomas Hudziec
Modified: 2019-08-14 15:01 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
.Nautilus does not hide icons in the GNOME Classic Session The GNOME Tweak Tool setting to show or hide icons in the GNOME session, where the icons are hidden by default, is ignored in the GNOME Classic Session. As a result, it is not possible to hide icons in the GNOME Classic Session even though the GNOME Tweak Tool displays this option.
Clone Of:
: 1679127 (view as bug list)
Environment:
Last Closed: 2019-08-14 15:01:57 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 785513 None None None 2019-08-07 20:12:44 UTC
Red Hat Bugzilla 1257763 None None None 2019-08-07 20:12:44 UTC
Red Hat Bugzilla 1454920 None CLOSED Desktop icons cannot be disabled 2019-08-14 15:01:13 UTC
Red Hat Bugzilla 1460768 None None None 2019-08-07 20:12:44 UTC

Internal Links: 1257763 1454920 1460768

Description Tomas Hudziec 2017-07-25 13:56:10 UTC
Description of problem:
Hiding icons on desktop via gnome-tweak-tool does not work.

Version-Release number of selected component (if applicable):
nautilus-3.22.3-3
gnome-tweak-tool-3.22.0-1

How reproducible:
100%

Steps to Reproduce:
1. open gnome-tweak-tool
2. click on Desktop tab
3. turn off "Icons on Desktop" switch

Actual results:
Icons on desktop should disappear.

Expected results:
Icons on desktop does not disappear.

Additional info:
When switch is on, checking checkboxes (with Home, Trash...) does work, though.

Comment 3 Rui Matos 2017-07-25 17:05:28 UTC
nautilus now ignores the gsetting when running under the classic session. enabling/disabling still works in a normal gnome session.

Comment 6 Tomas Pelka 2017-07-26 09:56:33 UTC
It is possible (and Carlos will confirm or disconfirm) that desktop icons option is not valid for gnome-classic session. If so it should be disabled in that case otherwise it is quite confusing.

Comment 7 Carlos Soriano 2017-08-07 09:09:12 UTC
(In reply to Tomas Pelka from comment #6)
> It is possible (and Carlos will confirm or disconfirm) that desktop icons
> option is not valid for gnome-classic session. If so it should be disabled
> in that case otherwise it is quite confusing.

As comment 3 points out yes, it's not valid to disable them in gnome-classic session. I'm not aware that this was ever possible.

I agree gnome-tweak-tool should disable that button when that's the case.

Comment 10 Matthias Clasen 2018-02-06 18:27:21 UTC
I agree that we should disable the button in classic mode, but I am not sure that this mostly cosmetic issue qualifies as a blocker.

Comment 12 Tomas Hudziec 2018-08-13 14:29:00 UTC
Still reproducible in RHEL 7.6 with:
gnome-tweak-tool-3.28.1-2.el7.noarch
gnome-classic-session-3.28.1-4.el7.noarch
nautilus-3.26.3.1-2.el7.x86_64

Comment 13 Vera Budikova 2018-08-14 05:07:03 UTC
Hello Tomas,
did you try it with clean installation? I have tried it and it is working for me in clean installation, but not in my "working RHEL".

Comment 14 Tomas Hudziec 2018-08-14 10:01:00 UTC
Hello Vera,
I tried on clean 7.6 installation on remote machine via VNC and it works. On my local working RHEL and RHEL in virtual machine, where both I have from version 7.3 it does not work.

Comment 15 Tomas Pelka 2018-08-14 11:26:50 UTC
@Carlos is there eventually some sort of nautilus/gnome-tweak-tools config that we should clean to switch back to default settings?

Comment 16 Carlos Soriano 2018-09-05 14:39:45 UTC
Seems Tweaks checks for that setting still, that's an issue upstream since it shouldn't check whether to show the button or not in that way. Will work with upstream for a solution.

Comment 17 Carlos Soriano 2018-09-06 13:15:37 UTC
I proposed a change upstream and I have a fix here, however it's missing the blocker flag (which I cannot see).

I guess it can wait til 7.7

Comment 26 Milan Crha 2019-06-19 16:19:16 UTC
This is a duplicate of bug #1460768, as long as this is about disabling/hiding the Show Icons on/off switcher in the Desktop section of gnome-tweaks. I'm not closing it as such for now, because it seems here is a longer discussion. The older bug contains a proposed patch, thus I'd close this as a duplicate of the other.

For me, with nautilus-3.26.3.1-6.el7.x86_64, in the "standard" (non-classic) session, the on/off doesn't hide icons, but that might be a question for nautilus, I believe, because it provides the functionality.

Comment 27 Milan Crha 2019-08-14 15:01:57 UTC

*** This bug has been marked as a duplicate of bug 1460768 ***


Note You need to log in before you can comment on or make changes to this bug.