Bug 147493 - glibc issue with javaws, waitid with no options set
glibc issue with javaws, waitid with no options set
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 138982 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-08 10:44 EST by Scot Harris
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-09 08:25:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scot Harris 2005-02-08 10:44:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

Description of problem:
Installed j2sdk-1_4_2_07-linux-i586.rpm from Sun.  When attempting to
run any java scripts using javaws provided by that package found 100%
of CPU was used by the javaws process and a zombie process had been
spawned.

Also tried j2re-1_4_2_04-linux-i586.rpm which was used on an FC2
system with the same scripts just fine.  Same failure mode under FC3.

I did find a similar problem identified as an issue in glibc,
apparently in older versions of glibc there was no sanity checking of
on the waitid call.  As such this would allow the call to complete and
execution of the script would continue.

I am not sure if this is a problem in javaws or glibc at this point. 
This does break all scripts using javaws under FC3.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install java package (any version) on FC3
2. use javaws to execute script
3. 
    

Actual Results:  CPU running at 100%
zombie process spawned

Expected Results:  Script runs successfully.  Works under FC2.

Additional info:
Comment 1 Sitsofe Wheeler 2005-02-08 14:56:39 EST
Dup of bug #138982
Comment 2 Jakub Jelinek 2005-02-09 08:25:25 EST
This is a javaws bug, not glibc bug.
http://www.opengroup.org/onlinepubs/009695399/functions/waitid.html
mandates that options is formed by OR'ing together one or more of the following
flags...
but javaws uses 0 for options.  Note one or more, not zero or more.

The difference from FC2 is that starting with FC3, glibc uses kernel waitid
syscall if available, while FC2 used just not very conformant wrapper around
waitpid and allowed many broken combinations of arguments.
Comment 3 Jakub Jelinek 2005-02-09 08:27:31 EST
*** Bug 138982 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.