Bug 147507 - After loading stage2 anaconda fails
After loading stage2 anaconda fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-08 12:44 EST by Armijn Hemel
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-28 10:02:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
vmware-rawhide-anaconda-text.png (43.70 KB, image/png)
2005-03-20 02:37 EST, Warren Togami
no flags Details

  None (edit)
Description Armijn Hemel 2005-02-08 12:44:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Doing an FTP install after booting from CD-ROM anaconda barfs after
successfully loading stage2, complaining it can't find libraries.
From the Python backtrace:

Could not find platform independent libraries <prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
'import site' failed: use -v for traceback
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 28, in ?
    import sys, os
  ImportError: No module named os

So, it seems like some sort of PATH problem.


Version-Release number of selected component (if applicable):
anaconda-10.2.0.16-1

How reproducible:
Always

Steps to Reproduce:
1. burn boot.iso to CD, start install
2. load stage2 image from FTP site and continue
3. install barfs
    

Actual Results:  Installer barfs

Additional info:
Comment 1 Jeremy Katz 2005-02-09 11:34:59 EST
There have been a lot of fixes in the past few days so this might be
better now.  Assigning to Chris to double check.
Comment 2 Chris Lumens 2005-02-09 13:08:49 EST
I'm unable to duplicate this problem, so I'll assume one of the million changes
we've made in the last couple days fixed it.  Feel free to reopen if you see it
in later rawhides or if we re-break things.
Comment 3 Armijn Hemel 2005-02-14 11:04:59 EST
I keep seeing this problem, also with the latest boot.iso (today) and older ones
(yesterday). I verified that the md5sums on the ISO and the CD are the same (in
fact, I had k3b verify that). What should I do to effectively debug this?
Comment 4 Armijn Hemel 2005-02-14 12:17:20 EST
I'm not able to reproduce this problem inside VMware or on a Dell Optiplex
GX260, but I can reproduce it repeatedly and reliably on Dell Optiplex GX110
machines (tested 5 so far).
Comment 5 Armijn Hemel 2005-03-02 13:34:26 EST
I'm still seeing this problem with the latest and greatest version of 5 minutes
ago (and various versions before that). I can't switch to another console to
debug the problem when it occurs, because the barfing of the installation
process halts the operating system. What should I do to debug this? Patching
anaconda and rebuilding the whole distribution is not a problem for me (done
that before),
I just don't know where to debug :S
Comment 6 Chris Lumens 2005-03-02 17:32:24 EST
Still can't reproduce this one.  What's the last screen you're seeing before it
fails?  Can you reproduce this using a method other than an FTP install?  Also
can you test your memory using memtest86?
Comment 7 Armijn Hemel 2005-03-02 17:43:26 EST
It downloads the image fine from FTP, then it barfs after it says "starting
anaconda". I'm pretty sure it's *not* a memory problem, because I can reproduce
this on at least 5 identical boxes (all Dell Optiplex GX 110 machines), but not
on any others. Which install method would you recommend (there are no ISOs
available, are there)?
Comment 8 Alain Volmat 2005-03-14 05:38:39 EST
I got the same problem on my system. Fedora-Devel (version of 03/13)
inside VMWare 5.0b3 (on the top of FC3).
In my case it happens when doing network install (from boot.iso) and
specifying "linux text" to perform text install.
Then perform HTTP install.
Comment 9 Peter Jones 2005-03-20 02:35:58 EST
Apparently when this happens there are no python modules in netsg2.img, at least
according to gb and msw (they're pretty reliable sources)
Comment 10 Warren Togami 2005-03-20 02:37:56 EST
Created attachment 112155 [details]
vmware-rawhide-anaconda-text.png

rawhide March 19th 2005 - it happened again
Comment 11 Warren Togami 2005-03-20 05:08:01 EST
Note that this is a text install only failure, while graphical install may work.
 This is because...

<msw> warren: it didn't have any python modules in netstg2.img or hdstg2.img
<warren> msw, oddly it works for graphical install, but not text
<msw> warren: right
<warren> oh
<msw> warren: stage2.img has all the modules you need
<msw> warren: but if you do a ftp,http,hd install in text mode, you'll use the
smaller images
Comment 12 Armijn Hemel 2005-03-20 05:30:44 EST
I find this really odd, because it did work when I used the same CD image and
same ftp install from another machine (other hardware) and from inside VMware,
but failed on all Dell GX-110 machines I have. I'm using graphical installs btw.
We might be looking at two different problems.
Comment 13 Chris Lumens 2005-03-21 14:26:39 EST
Okay, I believe this is being caused by errors in building the netstg2.img. 
Will roll a new anaconda package tonight.  Please test a rawhide tree from
tomorrow or later and verify that it works for you.
Comment 14 Armijn Hemel 2005-03-22 09:46:15 EST
Doesn't fix it for me. Is there some debug version I could run?
Comment 15 Chris Lumens 2005-03-22 10:41:11 EST
Ah, the error is still occurring because I only fixed half the problem.  Sorry
about that.  Please try tomorrow or later.
Comment 16 Wayne Walker 2005-03-22 23:10:20 EST
Having same problem where can I get the new netstg2.img to test? (Once it's done)
Comment 17 Wayne Walker 2005-03-22 23:27:03 EST
Copied stage2.img to netstg2.img on http server as implied above.  http install
(booted from cd, "linux text askmethod") works now.
Comment 18 Armijn Hemel 2005-03-24 12:01:25 EST
I don't get this problem anymore but a bunch of other errors unrelated to this
one instead ;-) So, I think this one can be safely closed...
Comment 19 Chris Lumens 2005-03-28 10:02:55 EST
Closing based on bug submitter comments.
Comment 20 Peter Jones 2005-03-30 16:20:06 EST
*** Bug 152610 has been marked as a duplicate of this bug. ***
Comment 21 Jared Greenwald 2005-04-01 13:16:26 EST
I tried this workaround (copying the stage2.img over the netstg2.img) and it
didn't work for me.  I'm sync'd to the latest dev tree as of last night
(2005-04-01) which is what I'd been told in #fedora-devel by a number of people.
 I'm not sure what I should try at this point...

Note You need to log in before you can comment on or make changes to this bug.