Bug 152610 - kickstart fails with python errors
Summary: kickstart fails with python errors
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 4
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-30 19:09 UTC by Jared Greenwald
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-12 15:52:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
file list (81.32 KB, text/plain)
2005-03-30 19:13 UTC, Jared Greenwald
no flags Details
file list (sorted) (81.33 KB, text/plain)
2005-03-30 19:56 UTC, Jared Greenwald
no flags Details

Description Jared Greenwald 2005-03-30 19:09:14 UTC
Description of problem:
I have a proven kickstart setup where I install via url method from a local
webserver.  I dumped the new FC4-1 isos into a diretory to use as the install
base.  The system boots and attempts to run anaconda, but falls on its face
before doing anything meaningful.

How reproducible:
Boot the boot.iso in the FC4-1 images directory of the CDs.

Steps to Reproduce:
1.Boot to a kickstart that references FC4-1.
  
Actual results:
The output on the screen looks something like this:

Running anaconda, the Fedora Core system installer - please wait...
Could not find platform independant libraries <prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
'import site' failed; use -v for traceback
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 28, in ?
    import sys, os
Import Error: No module named os
install exited abnormally
sending termination signals...done
sending kill signals...done

...it halts (but doesn't power off) after this point...


Expected results:
System install based on the kickstart file.

Additional info:

Comment 1 Jared Greenwald 2005-03-30 19:13:52 UTC
Created attachment 112472 [details]
file list

This is a list of files in the directory that I am pointing kickstart at.

Comment 2 Jared Greenwald 2005-03-30 19:56:50 UTC
Created attachment 112473 [details]
file list (sorted)

sorted version of previous attachment

Comment 3 Peter Jones 2005-03-30 21:19:58 UTC

*** This bug has been marked as a duplicate of 147507 ***

Comment 4 Jeremy Katz 2005-04-12 15:52:15 UTC
This should be fixed in test2

Comment 5 David Timms 2006-02-07 10:53:49 UTC
Jeremy, this exact error message is back for me with boot.iso and linux text for
ftp install. (minstg2.img 2006-02-07 7:16- 24,264,704B) (HP omnibook 4150 384Mram).
F3
...
looking for USB mouse...
Running anaconda script /usr/bin/anaconda

F4
...
<6>SGI XFS Quota Management subsystem
<6>device-mapper: 4.5.0-ioctl (2005-10-04) initialised: dm-devel@redhat.com


Note You need to log in before you can comment on or make changes to this bug.