Bug 147516 - expect problems with large amounts of output
Summary: expect problems with large amounts of output
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: expect   
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-08 18:10 UTC by Guy Jennings
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 18:02:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Guy Jennings 2005-02-08 18:10:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/125.5.6 (KHTML, like Gecko) Safari/125.12

Description of problem:
If you have an expect script that produces large amounts of output the output 'sticks' and repeats at some point.  This seems to be the same behavior described in bug
#147276 but I observe it in any terminal.  

[jennings@weimar ~]$ expect 
expect1.1> spawn perl
spawn perl
13403
expect1.2> interact
print $i++,"\n" while (1)
<ctrl-D>



Version-Release number of selected component (if applicable):
expect-5.42.1-1

How reproducible:
Always

Steps to Reproduce:
1. see above
2.
3.
    

Actual Results:  The output gets to about 10000 and starts to repeat.

Expected Results:  The output should count upwards until you stop it

Additional info:

Comment 1 David Cantrell 2006-01-31 16:11:26 UTC
I see this is an old bug report.  I just recently took ownership of the expect
package, so I'm trying to get caught up.

Two things:

1)  I can't do anything for FC3 as that's now unsupported.

2)  On rawhide (what will become FC5), I ran your test above and the problem
doesn't appear for me.  I let it run to 509003 and killed it.  Rawhide has
expect-5.43.

If you're running FC5 Test 2 or rawhide, can you confirm the behavior is fixed?

Comment 2 Guy Jennings 2006-01-31 17:18:24 UTC
Yes, it was fixed in a later version

Comment 3 David Cantrell 2006-01-31 18:02:52 UTC
OK, thanks.


Note You need to log in before you can comment on or make changes to this bug.