Bug 147553 - Cannot install kernel-devel packages for all archs in parallel
Cannot install kernel-devel packages for all archs in parallel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rik van Riel
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-09 02:43 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-01 01:46:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2005-02-09 02:43:07 EST
As discussed with David, the intention in the Rawhide kernel-devel packages is
to make it possible to install multiple of those for different archs in
parallel.  As shown below, it does not work for all of them.  David reported
that he was able to install the ppc and ppc64 devel packages in parallel, maybe
that's because of ppc64 being multiarch and "allowing" ppc packages too.


# rpm -q kernel-devel
package kernel-devel is not installed
# rpm -Uvh kernel-devel-2.6.10-1.1126_FC4.i586.rpm
kernel-devel-2.6.10-1.1126_FC4.i686.rpm
warning: package kernel-devel = 2.6.10-1.1126_FC4 was already added, replacing
with kernel-devel <= 2.6.10-1.1126_FC4
Preparing...                ########################################### [100%]
   1:kernel-devel           ########################################### [100%]
# ls /usr/src/kernels/
2.6.10-1.1126_FC4-i686
# rpm -Uvh kernel-devel-2.6.10-1.1126_FC4.i586.rpm
Preparing...                ########################################### [100%]
        package kernel-devel-2.6.10-1.1126_FC4 is already installed
# rpm -q --qf '%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}' kernel-devel
kernel-devel-2.6.10-1.1126_FC4.i686
Comment 1 Ville Skyttä 2005-02-09 02:45:50 EST
Oh, and "rpm -U" vs "rpm -i" does not affect the problem in any way.
Comment 2 Rik van Riel 2005-03-14 22:35:35 EST
Mmmm, not sure how to fix this bug in a backwards compatible way...
Comment 3 Rik van Riel 2005-03-15 10:54:52 EST
One aspect of this bug are file conflicts in /lib/modules/${KVERREL}/, in
particular the symlinks build and source.  Those can be fixed by moving the
symlinks into the kernel-* packages, out of kernel-*-devel, as suggested in bug
#149210.

I have proposed a patch for that today.
Comment 4 Rik van Riel 2005-03-29 14:53:21 EST
And indeed, RPM isn't willing to install the two - even though there are no
longer any file conflicts.  Over to fedora-maintainers to figure out what we
want to do...

# rpm -ivh i586/kernel-devel-2.6.11-1.1208_FC4.i586.rpm
i686/kernel-devel-2.6.11-1.1208_FC4.i686.rpm
warning: package kernel-devel = 2.6.11-1.1208_FC4 was already added, skipping
kernel-devel < 2.6.11-1.1208_FC4
error: error reading from file i586/kernel-devel-2.6.11-1.1208_FC4.i586.rpm
Comment 5 Rik van Riel 2005-05-19 16:22:57 EDT
I guess the code we have now is as far as we should go ;)
Comment 6 Ville Skyttä 2005-10-27 15:02:46 EDT
Cc'ing Jeremy per today's FESCO meeting.  Re: comment 5, no objections here. 

Note You need to log in before you can comment on or make changes to this bug.